Welcome to the PufferPanel community forums! If you need help please register an account and post in the Support category.

Issues creating a server after installation.



  • An error occurred while trying to connect to the remote node. Please check that the daemon is running and try again.
    An error occurred trying to add a server. () []
    

    This is the error I get after trying to make server.

    error.log

    [2019-03-27 04-18-38] PHP Notice: Undefined property: stdClass::$success in /srv/pufferpanel/src/routes/admin/server/routes.php:300  @  http://192.168.1.101:25566/admin/server/new 
    [2019-03-27 04-18-38] PHP Notice: Undefined property: stdClass::$msg in /srv/pufferpanel/src/routes/admin/server/routes.php:301  @  http://192.168.1.101:25566/admin/server/new 
    [2019-03-27 04-18-38] PHP Notice: Undefined property: stdClass::$code in /srv/pufferpanel/src/routes/admin/server/routes.php:301  @  http://192.168.1.101:25566/admin/server/new 
    

    systemctl status

    ● pufferd.service - pufferd daemon service
       Loaded: loaded (/lib/systemd/system/pufferd.service; enabled; vendor preset: enabled)
       Active: active (running) since Wed 2019-03-27 00:12:51 EDT; 25min ago
      Process: 4139 ExecStop=/usr/sbin/pufferd --shutdown $MAINPID (code=exited, status=0/SUCCESS)
     Main PID: 4150 (pufferd)
        Tasks: 10 (limit: 4915)
       CGroup: /system.slice/pufferd.service
               └─4150 /usr/sbin/pufferd --run
    
    Mar 27 00:12:51 media-server pufferd[4150]: [00:12:51] [INFO] No config passed, defaulting to /etc/pufferd/config.json
    Mar 27 00:12:51 media-server pufferd[4150]: [00:12:51] [INFO] pufferd 1.2.6 (e1db6eafa968018b955db659ac4ed1e943c75fda)
    Mar 27 00:12:51 media-server pufferd[4150]: [00:12:51] [INFO] Logging set to INFO
    Mar 27 00:12:51 media-server pufferd[4150]: [00:12:51] [WARN] No HTTPS.PEM found in data folder, will use http instead
    Mar 27 00:12:51 media-server pufferd[4150]: [00:12:51] [INFO] Started SFTP Server on 0.0.0.0:5657
    Mar 27 00:12:51 media-server pufferd[4150]: [00:12:51] [INFO] Starting web access on 0.0.0.0:5656
    Mar 27 00:14:10 media-server pufferd[4150]: [00:14:10] [ERROR] Error talking to auth server
    Mar 27 00:14:10 media-server pufferd[4150]: Post http://<myiphere>/oauth2/token/info: dial tcp <myiphere>:80: connect: connection refused
    Mar 27 00:18:38 media-server pufferd[4150]: [00:18:38] [ERROR] Error talking to auth server
    Mar 27 00:18:38 media-server pufferd[4150]: Post http://<myiphere>/oauth2/token/info: dial tcp <myiphere>:80: connect: connection refused
    

    I noticed in the systemctl logs it's trying to use port 80, not sure if that's related to my issue I tried changing it in the URL Settings in the control panel but that didn't seem to change anything.



  • As you are behind a NAT, you have to configure the daemon to use your local IP to talk to your panel. (That config is located in /etc/pufferd).

    You'd also need to update the Nginx config to let it listen to that IP as well for the panel.



  • Thanks changing that to use the right port and my local ip worked.



  • I have one other issue in my installation apparently pufferpanel isn't finding the daemon.

    http://192.168.1.101:25567/node/<myip>:5656
    

    Is where the error links me to.

    If I got to http://192.168.1.101:5656 however it is running. I'm not sure where pufferpanel is pulling that ip now because it's no longer in the pufferd config or the pufferpanel config.



  • Found it, it was in the node settings.


Log in to reply
 

3
Online

972
Users

933
Topics

3.7k
Posts