Welcome to the PufferPanel community forums! Please visit our discord for support: https://discord.gg/YwUXaD6

PDO [2002] Error while installing on a rented VPS

  • Hello!

    I installed PufferPanel on my laptop with a virtualization software named Parallels Desktop (for the ones who knows, it's a software that runs on a mac) - and - it works without errors. Server creation, etc, everything works. I used this VM as as "test server" running Debian 8.

    This morning, I moved to a rented VPS. I tried to install the panel, works, I can create users, and this like that. When it comes to server creation, there's a big problem :
    Yeah I have the Dark Reader extension on Google Chrome

    So, I checked my logs.

    Pufferd 1.2.5 :

    [09:12:08] [INFO] pufferd 1.2.5 (e097cfead655ffcdf834********************)
    [09:12:08] [INFO] Logging set to INFO
    [09:12:08] [INFO] Config saved

    "Exception Log" :

    [2018-12-10 09-51-52] PDOException: SQLSTATE[HY000] [2002] No such file or directory #2002 in /srv/pufferpanel/vendor/j4mie/idiorm/idiorm.php:328  @  http://**********.fr/admin/server/new  @@  exception--2018-12-10--09-51--05e1af0257.html

    And yup I got a html file.

    Call stack :

    /srv/pufferpanel/vendor/j4mie/idiorm/idiorm.php:328	source  PDO->__construct(arguments)
    /srv/pufferpanel/vendor/j4mie/idiorm/idiorm.php:311	source  ORM::_setup_db(arguments)
    /srv/pufferpanel/vendor/j4mie/idiorm/idiorm.php:2291	source  ORM::for_table(arguments)
    /srv/pufferpanel/src/core/authentication.php:43	source  ORM::__callStatic(arguments)

    At the line 43 :

    43:            $this->select = (!isset($_COOKIE['pp_auth_token']) || empty($_COOKIE['pp_auth_token'])) ? false : ORM::forTable('users')->where(array('session_ip' => $_SERVER['REMOTE_ADDR'], 'session_id' => $_COOKIE['pp_auth_token']))->findOne();

    Source file :


    At the line 328 :

    328:                        self::$_config[$connection_name]['driver_options']

    Any help would be appreciated.



  • Update :
    This problem came from my provider.

    I changed the server and it worked again. Thanks.