SCRDS - Server Not Fully Loading?



  • Hi,

    Recently installed PufferPanel, its installed SCRDS successfully on the node and subsequently launches:

    http://hastebin.com/socujetayo.vbs

    However i don't believe the server is fully loading and we are unable to connect.

    http://hastebin.com/gayedoyuji.vhdl

    [2016-02-19 06:46:15] [VERBOSE] Attempting to spawn server process for pp-tester_n7dxy
    [2016-02-19 06:46:15] [VERBOSE] Executing for startup: su -s /bin/bash -l pp-tester_n7dxy -c cd ./public && ./srcds_run -game garrysmod -console +map ${map} -maxplayers 20 -norestart
    [2016-02-19 06:46:15] [VERBOSE] Process started with pid 23729

    Best Regards



  • Hmm, the problem there is that SCRDS determined your IP was 127.0.0.1, which is not correct at all.

    When you installed the server and the node, did you declare that the IPs were 127.0.0.1 at any point?



  • Hi,

    This is the template i used http://imgur.com/hutzT3p. At no point did i define 127.0.0.1

    Please note i blurred the last 3 octets from the ip address.

    Cheers for the reply!



  • @Stigin That is what I feared. I believe SCRDS uses an automatic IP detection system (at least, from what I understand of it), and so my first thought is that it is not grabbing your IP correctly, which is resulting in it failing.

    Taking a look though, you should be able to change the startup command that is used, and add the following:
    +ip 123.123.123.124
    (replacing the IP of course)
    (http://www.srcds.com/db/engine.php?subaction=showfull&id=1102717219&archive=)



  • @LordRalex Got it to work! Reinstalled the node not too sure what was wrong, second time round was the charm.

    Now i have issues with SFTP denying connections - I've tried updating scales to no avail.

    Any ideas?

    Appreciate the feedback.



  • What is in the SSH logs?



  • http://hastebin.com/egajemugox.coffee

    SFTP - it goes connection to "ip" refused

    The server rejected SFTP connection but listens for FTP

    -- Not too sure whats going on!



  • SFTP is handled purely by your existing SSH service. I do not see your connections occurring there at all. You are connecting using the node's IP + the SSH port, correct?



  • Yes that's correct, we're using the ip, the 22 port as well as well as the correct information for the user who has the server.



  • @LordRalex - It's interesting, After installing the auto deploy script on the node, it denies SSH putty connections from root as well?



  • No, the only part of SSH that we touch is to add a Match rule for the scalesuser group (which is what allows for the SFTP jails). If you cannot use root now, then it means that someone also changed that file, but never restarted the SSH service so it would apply.



  • I've tried this on 4 fresh instances from Vultr, After a reboot they all start denying SSH connections and this is without touching anything apart from running the auto-deploy script.



  • We do not touch any of those settings, so I am finding it hard to believe we are doing it.

    Can you provide the sshd config before and after you do an install? I suspect Vultr may be providing something that's doing it.



  • Here you go! As requested, I have confirmed after the install and a reboot SSH is rejected!
    http://hastebin.com/ezuduxonut.vala



  • @Stigin that link is dead for me



  • Okay, so the configs are not changing what I would expect, so it's acting like the config is now bad, which is not good.

    Can you get the SSH logs from when you start the service?



  • Hi Lord,

    I restarted the SSH service and SCP'd the auth.log out to another vps to download it.

    http://hastebin.com/sahezonebe.vhdl



  • Can you provide the service startup logs as well? Want to know if there's something failing after we do the install.

    Does SSH just say connection refused or is it just denying the root user?



  • Hi, Connection says refused for any user including root.

    Are you able to tell me the specific log file you are looking for?

    Cheers



  • Then it means the service stopped running. The specific file would depend on the distro of Linux you are using.


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.