Error when installing scales on Ubuntu 15.10



  • Hi!
    I followed the instructions on how to install PufferPanel and Scales.
    I installed on Ubuntu v15.10 x64 DESKTOP running in a vm (if that matters).

    I encountered a problem where the auto-deploy script would fail with the error:
    "sed: can't read /etc/ssh/sshd_config: No such file or directory"

    Quick search for that error suggested I had to install the package "openssh-server".
    That seems to have fixed the issue and the script ran through without error this time.

    Just wanted to share my experience, if this package is really required it should be added to the deployment script and installed automatically :)

    Keep up the great work!



  • The auto-deploy is really meant for the server versions of the distributions, not the desktop ones, and openssh-server is usually already installed with the server versions. Glad you got it working though.



  • But it doesn't harm making sure by putting it in, does it? I mean the PufferPanel installation instructions start with making sure that all dependencies are installed. Maybe one of those small blue additional-information notes could be left under the "System Requirements" bit here (http://scales.pufferpanel.com/docs/getting-started) that says something like: "If you are using the desktop version of one of these distros, make sure that the package 'openssh-server' is installed", and maybe a line of code "sudo apt-get install openssh-server" to copy & paste.



  • We do not support the desktop versions at this time otherwise I would indeed put it in, there are other issues you may run into with Scales if you are going to run that on the same machine (make sure you have -nogui for the Minecraft launch options).



  • Alright then, I didn't know that. I'll keep experimenting, I might setup a server version of ubuntu soon to have scales run on there.
    I'm really excited to try the panel out, and it can only become better! :)



  • I just set up a server version using vmware easy install.
    According to this page (https://help.ubuntu.com/lts/serverguide/openssh-server.html) openssh is an optional feature during installation (VMware did not select that for me).
    That means one can't be sure it is installed on all systems, even if they are runnging the server version of ubuntu.

    I don't know a lot about linux programming and git (sadly) so I don't think I can figure out how to suggest a change to the script.

    But well anyone willing to spend a minute on google will find a solution anyway, and now it's even documented here, so it's really neglectible.
    The panel works great now, I have a lot of fun with it!
    The documentation and information offerd by the ui is also great.


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.