Welcome to the PufferPanel community forums! Please visit our discord for support: https://discord.gg/v8dz49e

Can't do anything with a server.



  • @lordralex This is what it gave to me when attempting to Start,Restart,Stop and Install

    [16:47:23] [INFO] pufferd v1.2.4 (bf777b97c88b3dd92b3bdc630bb39115ae921be5)
    [16:47:23] [INFO] Logging set to INFO
    [16:47:23] [DEBUG] Checking for updates using https://dl.pufferpanel.com/pufferd/v1.2/version.txt
    [16:47:23] [DEBUG] Loading server as docker
    [16:47:23] [INFO] Loaded server a55961fd-b3d4-4add-9d78-7b68b4cdb4f0
    [16:47:23] [DEBUG] Loading existing key
    [16:47:23] [INFO] Started SFTP Server on 0.0.0.0:5657
    [16:47:23] [INFO] Starting web access on 0.0.0.0:5656
    [16:47:40] [DEBUG] [163.172.177.102:36180] [HEAD] [/]
    [16:47:40] [DEBUG] [85.190.77.209:51370] [GET] [/server/a55961fd-b3d4-4add-9d78-7b68b4cdb4f0/console?accessToken=---]
    [16:47:40] [DEVEL] map[scope:server.start server.stop server.install server.file.get server.file.put server.file.delete server.kill server.log server.console server.console.send server.stats server.network sftp server.create server.delete server.edit server.reload node.stop client_id:.internal_1_1 username:1 server_id:a55961fd-b3d4-4add-9d78-7b68b4cdb4f0 active:true]
    [16:49:20] [DEBUG] [163.172.177.102:36274] [HEAD] [/]
    [16:49:21] [DEBUG] [85.190.77.209:51395] [GET] [/server/a55961fd-b3d4-4add-9d78-7b68b4cdb4f0/console?accessToken=---]
    [16:49:21] [DEVEL] map[server_id:a55961fd-b3d4-4add-9d78-7b68b4cdb4f0 active:true scope:server.start server.stop server.install server.file.get server.file.put server.file.delete server.kill server.log server.console server.console.send server.stats server.network sftp server.create server.delete server.edit server.reload node.stop client_id:.internal_1_1 username:1]
    
    


  • Yeah, none of those are the browser nor the panel contacting pufferd.

    What is in your "Network" tab in the browser? There should be one to "/start".



  • @lordralex alt text (Sorry, it's in french)

    My browser is the Nigthly version of Firefox.



  • What I mean is:

    Press F12 when you are in the panel. In the area that shows up, select "Network".

    Refresh the page, then try to start your server. In the area that showed up prior, select the one with the "/start".



  • @lordralex This is what it give.

    alt text



  • Good, what is in that "Response" part?





  • Well, that's certainly.... interesting.

    All the data looks correct, but somehow that response is definitely not what we expected. That is not the daemon or the panel triggering.

    Interestingly, the socket connection worked, but that's not.

    Did you have any issues installing the panel or the server originally?

    I do see HTTPS in use, but seems like at a glance it'd be configured correctly for the websocket to connect properly.



  • @lordralex No any problem when installing the panel or the server.
    HTTPS is installed correctly by following the tutorial



  • Something does not line up then, because it should be using similar calls.

    When you go to view all of your servers, does it show the address correctly? Or does it remain empty?



  • @lordralex It remain empty



  • Can you do the same thing with the network tab there and look for "server-status" (I think it's that one).

    I want to see if it's returning the same thing.

    Either way, something is definitely up with this. That is not a pufferpanel error, and pufferd doesn't even see the call.

    The fact the API does handle errors right (as in, you call it without the auth or for a missing server) means our code is running, but there should not be a reason that garbage comes back.

    I'd hate to ask how hard it'd be to switch to nginx as a test? Apache has caused issues in the past, and while I'm 90% sure it's not the issue, I want to test that theory.



  • @lordralex This is the response for server-status
    alt text



  • That is.... interesting.

    It did not error, but there's no data there. That would indicate when it tried to access that node, it failed.

    When you did the SSL change, you would have updated the node settings in the panel. You did this correct? So that both the public and private IP for the node is the same?



  • @lordralex Don't really know, but this is a screenshot
    alt text



  • I just tried with NGINX and it always return a 502 Bad Gateway



  • I don't see the screenshot for the first one.

    Nginx is a bit more work to set up, so if you can't get it working quickly, don't bother.



  • @lordralex And now ?
    alt text



  • Change the "Private IP" to fyro.ga



  • @lordralex OMG, Thanks you ! It's now working perfectly fine !


Log in to reply
 

4
Online

1.1k
Users

946
Topics

3.8k
Posts