Garry's Mod DarkRP Gamemode F4 Menu Issues



  • I have created a Garry's Mod Server and installed the Gamemode "DarkRP" on it, all seems to be working fine until i try to install a custom F4 menu for the server. If i do this on a copy of the server that i have that is not connected to pufferpanel, then it works fine. However, if i try to install the menu on the pufferpanel version, the menu does not show when i press F4.

    Any help greatly appreciated, thanks in advance :)



  • @bitbyte

    Check if the server is actually running the DarkRP gamemode and not just sandbox
    (PufferPanel doesn't have a built in template to easily do this, you'll need to edit your server definition JSON file, edit the server.cfg, or use this modified template)

    Otherwise, running GMod on PufferPanel should not be any different than running it elsewhere.



  • yeah, ive done that. Ive been playing around in the gamemode. Everything else is working minus a custom F4 menu. I've tried 2 other ones and they both do the same :/



  • It must be me overlooking something somewhere... I'll triple check the settings and report back



  • Fixed it, forgot to restart puffer panel's daemon so it didnt read commandline changes which the DRM for the script needed



  • Glad it works!


 

3
Online

834
Users

851
Topics

3.6k
Posts