Error 404 on Pufferpanel Installation w/ Apache



  • Hi! As a precursor, I'm using Apache2 instead of nginx, and I'm trying to access it with a subdomain, panel.<domain>.tk and I'm a bit stuck at the moment.

    After having followed the guide to setting up multiple apache2 webservers at this guide, I confirmed that the sites worked with the simple index.html file (Panel.<domain>.tk directed correctly and so did <domain>.tk).

    After this, I did the install steps at this link except extracting the files to "/var/www/panel.<domain>.tk"

    I then edited my panel.<domain>.tk.conf file in /etc/apache2/sites-available/panel.<domain>.tk.conf to reflect that and point panel.<domain>.tk to /var/www/panel.<domain>.tk/public (the /var/www/panel.<domain>.tk folder is the unzipped .tar.gz file, just renamed) Here's that file.
    However, after doing this, all I get when going to panel.<domain>.tk is an error 404 "The requested URL /index was not found on this server." I'm not really sure what to do at this point, so any help is appreciated.

    I'm not sure what else to include, but anything you need I'm happy to provide for the sake of getting this running. Thanks in advance!



  • Multiple weird and fun things happened on this trip!

    1! For some reason or another, apache refused to acknowledge the existence of index.php at my initial pufferpanel install location (which was not /srv/pufferpanell). after installing at /srv/pufferpanel however, and changing the hosts file, voila, it would recognize it! (and therefore stop sending the 404 errors. apache was looking for /index.html and refused to go any further) But alas, now pufferpanel was throwing a 500 error! Aaah! Long story short, the pufferpanel mysql database and user never got made. as soon as those were made, everything worked fine.
    Thanks to Nebcore/Disconsented for being super helpful in the discord, and bearing with me as I stumbled through everything.


 

3
Online

818
Users

840
Topics

3.5k
Posts