Website not showing up



  • Okay im a noob at this so dont know much but I followed the instructions at https://www.pufferpanel.com/docs/getting-started using the centos7 option and everything worked however when i go to my panel page it shows a page that says
    "Welcome to nginx on Fedora!
    This page is used to test the proper operation of the nginx HTTP server after it has been installed. If you can read this page, it means that the web server installed at this site is working properly.

    Website Administrator
    This is the default index.html page that is distributed with nginx on Fedora. It is located in /usr/share/nginx/html.

    You should now put your content in a location of your choice and edit the root configuration directive in the nginx configuration file /etc/nginx/nginx.conf."
    Can any one help me?



  • See if there's a default conf file in /etc/nginx/sites-enabled
    If there is a default conf, try removing the default conf and then restarting nginx.

    In the same folder, there should also be a conf file called pufferpanel.conf, so make sure that's there.
    If there isn't, try running the following as root

    # cd /srv/pufferpanel
    # ./pufferpanel addnginx
    

    then restart nginx.



  • I checked the /etc/nginx path and there is no /etc/nginx/sites-enabled the only folders are conf.d and default.d
    I tried the commands that you had stated and they did not work.


 

4
Online

789
Users

819
Topics

3.5k
Posts