Welcome to the PufferPanel community forums! Please visit our discord for support: https://discord.gg/v8dz49e

Failed to get plugin information

  • Hi.

    I have installed Pufferpanel (and pufferd) on the same dedicated server. As for now there is no SSL configured.

    The installation seems to have worked without errors, but when I tried to create a new server I got this error:

    Failed to get plugin information for the selected node, please check your logs (ERR undefined)

    None of the logs I could find stated anything about errors.
    I looked in /var/log/pufferd/ and /srv/pufferpanel/logs/. Are there logs anywhere else?

    The pufferd node seems to be working, green sign as status in "Configured Nodes".

    It might be the same problem as: https://community.pufferpanel.com/topic/724/can-t-create-new-server
    though I don't have the same logs:

    [18:06:40] [INFO] pufferd v1.2.0 (115321293d74045ab0cab357c5c82bf07bafe55b)
    [18:06:40] [INFO] Logging set to INFO
    [18:06:41] [DEBUG] Loading existing key
    [18:06:41] [INFO] Started SFTP Server on
    [18:06:42] [INFO] Starting web access on
    [18:06:42] [DEBUG] Checking for updates using https://dl.pufferpanel.com/pufferd/v1.2/version.txt
    [18:06:43] [INFO] DL server reports a different hash than this version, an update may be available
    [18:06:43] [INFO] Installed: 115321293d74045ab0cab357c5c82bf07bafe55b
    [18:06:43] [INFO] Online: 115321293d74045ab0cab357c5c82bf07bafe55b

    Hope any of you can help!

  • Does the Javascript window show anything?

    This is not a usual error.

    If you go to https://<yourpanel>/admin/server/new/plugins what does it show?

  • It says:


  • Hi again.
    After some pokin around, I found out that I could't log in to mysql at all.
    So I made a fresh install of Ubuntu, and it all works now.
    Sorry if I got in the way of a bug hunt.

  • I said that too early.

  • I know its old but I came across this error also, to fix it I just needed to edit the premade node 'LocalNode' that was generated on installation.

    I removed from the Node Private IP so it would instead automatically pickup the domain I'd setup.

    Hope that helps someone else.

  • i have this problem too!

  • I had the same problem. @WillyJenkins answer worked for me!

Log in to reply