MTA console isn't showing up until server is stopped



  • So my problem is, that i created a template for mta, but the console output isn't showing up, until i stop the server.

    Starting server
    Server stopped
    MTA:BLUE Server for MTA:SA
    
    ==================================================================
    = Multi Theft Auto: San Andreas v1.5.4 [64 bit]
    ==================================================================
    = Server name      : Default MTA Server
    = Server IP address: auto
    = Server port      : 22003
    = 
    = Log file         : ..o_linux_x64/mods/deathmatch/logs/server.log
    = Maximum players  : 32
    = HTTP port        : 22005
    = Voice Chat       : Disabled
    = Bandwidth saving : Medium
    ==================================================================
    [18:22:42] File 'settings.xml' not present, creating new node.
    [18:22:43] Resources: 197 loaded, 0 failed
    [18:22:43] Starting resources...
    [18:22:43] Admin access list successfully updated 
    [18:22:43] INFO: Admin added 499 missing rights
    [18:22:43] Server minclientversion is now 1.3.0-9.04311
    [18:22:43] Gamemode 'play' started.
    [18:22:43] Authorized serial account protection is enabled for the ACL group(s): `Admin`  See http://mtasa.com/authserial
    [18:22:43] WARNING: <owner_email_address> not set
    [18:22:43] Server started and is ready to accept connections!
    [18:22:43] To stop the server, type 'shutdown' or press Ctrl-C
    [18:22:43] Type 'help' for a list of commands.
    [18:22:43] Querying MTA master server... success! (Auto detected IP:x.x.x.x)
    [18:23:29] Available commands:
    
    start                    stop                     stopall                  
    restart                  refresh                  refreshall               
    list                     info                     upgrade                  
    check                    say                      teamsay                  
    msg                      me                       nick                     
    login                    logout                   chgmypass                
    addaccount               delaccount               chgpass                  
    shutdown                 aexec                    whois                    
    whowas                   debugscript              help                     
    loadmodule               unloadmodule             reloadmodule             
    ver                      sver                     ase                      
    openports                debugdb                  reloadbans               
    aclrequest               authserial               debugjoinflood           
    debuguptime              sfakelag                 
    [18:23:34] SHUTDOWN: Got shutdown command from Console (No reason specified)
    [18:23:34] Server stopped!
    [18:23:34] Stopping resources......................
    [18:23:34] Closing SQLite3 database
    


  • What does your template look like?



  • This post is deleted!


  • @LordRalex

    {
      "pufferd": {
        "type": "mta",
        "display": "Multi Theft Auto - Latest",
        "install": {
          "commands": [
            {
              "commands": [
                "wget http://linux.mtasa.com/dl/multitheftauto_linux_x64.tar.gz",
                "wget http://linux.mtasa.com/dl/baseconfig.tar.gz",
                "tar -xf multitheftauto_linux_x64.tar.gz",
                "tar -xf baseconfig.tar.gz",
                "mv ${rootdir}/baseconfig/ ${rootdir}/deathmatch/",
                "mv ${rootdir}/deathmatch/ ${rootdir}/multitheftauto_linux_x64/mods/",
                "mkdir ${rootdir}/multitheftauto_linux_x64/mods/deathmatch/resources",
                "wget http://mirror.mtasa.com/mtasa/resources/mtasa-resources-latest.zip -P ${rootdir}/multitheftauto_linux_x64/mods/deathmatch/resources",
                "unzip ${rootdir}/multitheftauto_linux_x64/mods/deathmatch/resources/mtasa-resources-latest.zip -d ${rootdir}/multitheftauto_linux_x64/mods/deathmatch/resources/",
                "rm -f multitheftauto_linux_x64.tar.gz",
                "rm -f baseconfig.tar.gz",
                "rm -f ${rootdir}/multitheftauto_linux_x64/mods/deathmatch/resources/mtasa-resources-latest.zip"
              ],
              "type": "command"
            }
          ]
        },
        "run": {
          "stop": "shutdown",
          "pre": [],
          "post": [],
          "arguments": [],
          "program": "./multitheftauto_linux_x64/mta-server64"
        },
        "environment": {
          "type": "standard"
        },
        "data": {
          "port": {
            "value": "22003",
            "required": true,
            "desc": "What port to bind the server to",
            "display": "Port",
            "internal": false
          }
        }
      }
    }
    


  • Try using "tty" as the type of environment instead of standard.



  • @LordRalex now it's spams the console, with theese:

    (B(B|
    (B(B/
    (B(B-
    (B(B\
    (B(B|
    (B(B/
    (B(B-
    

    And some outputs look like this:

    (Bs(Bh(B(B|(Bu(Bt(B(B/(Bd(Bo(B(B-(Bw(Bn(B
    

 

3
Online

834
Users

851
Topics

3.6k
Posts