Can't create server



  • Hello,
    I installed pufferpanel but I get this error when I create a server:

    The home directory for the user (/home/pp-bungee_b5s9r/public) does not exist on the system.
    error: unable to contact remote service to alert to completed install process.

    logs:


    scales/logs/:
    [2016-01-31 17:49:43] [ERROR] Unable to complete the installer process. Please check the logs for more information.
    Error: An error was encountered with the installer script for 0b8cee92-ac33-4b07-84cf-e9cf7912163c. Script edited with code 1 and was logged to ./logs/installer/0b8cee92-ac33-4b07-84cf-e9cf7912163c-2016.01.31.17.49.38.log
    at Socket.<anonymous> (/srv/scales/lib/process.js:832:37)
    at emitTwo (events.js:87:13)
    at Socket.emit (events.js:172:7)
    at Terminal.emit (/srv/scales/node_modules/pty.js/lib/pty.js:306:27)
    at Socket.<anonymous> (/srv/scales/node_modules/pty.js/lib/pty.js:114:14)
    at Socket.g (events.js:260:16)
    at emitOne (events.js:82:20)
    at Socket.emit (events.js:169:7)
    at Pipe._onclose (net.js:469:12)

    pufferpanel/logs/:
    [2016-01-31 16-42-27] Exception: An error occured trying to add a server. ({"error":"An exception occurred trying to process this request."}) [HTTP 1.1/500] in /srv/pufferpanel/src/routes/admin/server/routes.php:826 @ http://51.255.198.9/admin/server/new @@ exception--2016-01-31--16-42--e5532c4933.html

    Pufferpanel created this error file:
    https://sharpswords.net/i/163109040057.png


    Sorry for my bad English, I'm Dutch. ;)



  • Could you include the log from ./logs/installer/0b8cee92-ac33-4b07-84cf-e9cf7912163c-2016.01.31.17.49.38.log under your scales server please and thanks. So under /srv/scales/logs/installer/0b8cee92-ac33-4b07-84cf-e9cf7912163c-2016.01.31.17.49.38.log

    Thanks.



  • I am also having the same issue and my log (at /logs/installer/4a028648-0fc0-45d9-aad4-a80c870ef492-2016.01.31.22.48.56.log) is the following:

    The home directory for the user (/home/pp-minecr_d5mxb/public) does not exist on the system.
    === Script exited with code 1 ===

    Also, when in debug mode, this appears in the command line.



  • This was due to a bug within the software, please re-create your servers through the panel or override your existing files with the latest version of scales (https://github.com/PufferPanel/Scales/archive/0.2.4.2.tar.gz)



  • So can I not just install scales on a fresh ubuntu server and it should work? Thanks.



  • I still get this error when doing so:

    installer:~$ rm -rf *
    installer:~$ curl -o BuildTools.jar https://hub.spigotmc.org/jenkins/job/BuildTools/lastSuccessfulBuild/artifact/target/BuildTools.jar
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed

    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    42 3331k 42 1420k 0 0 1427k 0 0:00:02 --:--:-- 0:00:02 1425k
    100 3331k 100 3331k 0 0 2104k 0 0:00:01 0:00:01 --:--:-- 2105k
    installer:~$ git config --global --unset core.autocrlf
    error: could not lock config file /home/pp-builds_te1lz/.gitconfig: Permission denied
    installer:~$ java -jar BuildTools.jar
    Loading BuildTools version: git-BuildTools-5861ac0-46 (#46)
    Git name not set, setting it to default value.
    Exception in thread "main" java.lang.RuntimeException: Error running command, return status !=0: [git, config, --global, user.name, BuildTools]
    at org.spigotmc.builder.Builder.runProcess(Builder.java:535)
    at org.spigotmc.builder.Builder.main(Builder.java:154)
    error: could not lock config file /home/pp-builds_te1lz/.gitconfig: Permission denied
    An error occurred while installing.
    error: unable to contact remote service to alert to completed install process.



  • I created a brand new server, installed scales, ran a server from pufferpanel and get this error above, i'm not too sure what I can do. Im positive that its the latest scales too.



  • @LordRalex This works, thank you!



  • @Mr_TiTan It is a bug within our code, due to how folder permissions need to work for various functions. Since spigot needs to build, it's different from the others, and so in this case, is causing the problem. I'm working on a fix for this, but it may take a bit due to the late hour.



  • @LordRalex Hey Thanks. Also if you want I can give you access to my server and pufferpanel for further diagnosing, if that would help.

    Thanks.



  • @Mr_TiTan I have deployed a fix. You will need to download the latest release from https://github.com/PufferPanel/Scales/releases and reinstall the server.



  • @LordRalex Hey, thanks for the Update it has fixed the Problem! Scales, and the Minecraft server have installed without any errors! :D However when I click start server it gives me the following:

    Server is starting...

    ---------Running Pre-Flight, this might take a moment or two...---------

    And then it never starts. I know Java is installed along with the port it wants to use is open and not in use by any other running process. Im not too sure what the problem may be because the log for proc.log says nothing useful about the server starting and in the install folder there is one log file and it has no useful information about the server starting either.

    Thanks for the Great Support :D



  • @Mr_TiTan said:

    Please provide the complete Scales log from /srv/scales/proc.log



  • @LordRalex Hey, so in my logs folder there is no proc.log but there is a proc1.log. Which contains: http://pastebin.com/BDHjQQMV


    Thanks for the Great Support.


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.