Bad Gateway



  • My panel was working without encryption, but after installing my certs the panel won't talk to the daemon.

    When I attempt to start or stop a server in the panel, I see {{ }} (Bad Gateway) pop up.

    In the pufferpanel log:
    [2017-08-21 18-54-55] Klein\Exceptions\UnhandledException: Daemon not available in /srv/pufferpanel/vendor/klein/klein/src/Klein/Klein.php:954 caused by Exception: Daemon not available in /srv/pufferpanel/src/core/daemon.php:239 caused by Unirest\Exception: Failed to connect to 127.0.0.1 port 5656: Connection refused in /srv/pufferpanel/vendor/mashape/unirest-php/src/Unirest/Request.php:476 @ https://<myhost>/daemon/server/2aa2f1aa-3a50-488e-872b-45a8e94c8735/stats @@ exception--2017-08-21--05-17--42f2791690.html

    If point my desktop chrome to https://<myhost>:5656/ I get {"success":true,"msg":"pufferd is running"}.

    However, if I run curl to localhost:5656 it doesn't like the certificate. I'm not sure if that is the root of the problem, but I attempted to add the intermediate CA to /usr/share/ca-certificates and /etc/ssl/certs with no effect on the error.



  • this is why ive never bothered setting up encryption on my instance - the ssl needs to be setup on the panel end AND the pufferd end, and i find the docs on doing so rather lacking
    im sure someone on the discord will be able to help you though



  • After reading more reading, I realized that trying to install the intermediate cert in /usr/share/ca-certificates or /etc/ssl/certs was wrong. Instead, I needed to concatenate my host certificate with the intermediate certs in the PEM file I give to pufferd and nginx.

    Now things are working again.


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.