PufferPanel 0.8.5 SFTP issue



  • So I have been updated to the new 0.8.5 pufferpanel and I met the following errors. It works with 0.8.4 and root access with sftp but scales login seems to have bugged. :(

    Response: fzSftp started, protocol_version=4
    Command: open "pp-bungee_vz9ii@104.199.128.119" 22
    Command: Trust new Hostkey: Once
    Command: Pass: ***********************
    Error: Network error: Software caused connection abort
    Error: Could not connect to server



  • What are your logs from your SSH service? I'm curious what is causing this problem.



  • @LordRalex
    Jan 25 15:04:45 instance-4 sshd[30916]: Accepted password for pp-advent_z4sxd from 115.135.25.211 port 52974 ssh2
    Jan 25 15:04:45 instance-4 sshd[30916]: pam_unix(sshd:session): session opened for user pp-advent_z4sxd by (uid=0)
    Jan 25 15:04:45 instance-4 sshd[30994]: fatal: bad ownership or modes for chroot directory "/home/pp-advent_z4sxd"
    Jan 25 15:04:45 instance-4 sshd[30916]: pam_unix(sshd:session): session closed for user pp-advent_z4sxd
    Jan 25 15:04:51 instance-4 sshd[30995]: Accepted password for pp-advent_z4sxd from 115.135.25.211 port 52975 ssh2
    Jan 25 15:04:51 instance-4 sshd[30995]: pam_unix(sshd:session): session opened for user pp-advent_z4sxd by (uid=0)
    Jan 25 15:04:51 instance-4 sshd[31048]: fatal: bad ownership or modes for chroot directory "/home/pp-advent_z4sxd"
    Jan 25 15:04:51 instance-4 sshd[30995]: pam_unix(sshd:session): session closed for user pp-advent_z4sxd
    Jan 25 15:04:57 instance-4 sshd[31049]: Accepted password for pp-advent_z4sxd from 115.135.25.211 port 52978 ssh2
    Jan 25 15:04:57 instance-4 sshd[31049]: pam_unix(sshd:session): session opened for user pp-advent_z4sxd by (uid=0)
    Jan 25 15:04:57 instance-4 sshd[31103]: fatal: bad ownership or modes for chroot directory "/home/pp-advent_z4sxd"
    Jan 25 15:04:57 instance-4 sshd[31049]: pam_unix(sshd:session): session closed for user pp-advent_z4sxd
    Jan 25 15:05:05 instance-4 passwd[31122]: pam_unix(passwd:chauthtok): password changed for pp-advent_z4sxd
    Jan 25 15:05:08 instance-4 sshd[31123]: Accepted password for pp-advent_z4sxd from 115.135.25.211 port 52985 ssh2
    Jan 25 15:05:08 instance-4 sshd[31123]: pam_unix(sshd:session): session opened for user pp-advent_z4sxd by (uid=0)
    Jan 25 15:05:08 instance-4 sshd[31176]: fatal: bad ownership or modes for chroot directory "/home/pp-advent_z4sxd"
    Jan 25 15:05:08 instance-4 sshd[31123]: pam_unix(sshd:session): session closed for user pp-advent_z4sxd
    Jan 25 15:05:14 instance-4 sshd[31177]: Accepted password for pp-advent_z4sxd from 115.135.25.211 port 52986 ssh2
    Jan 25 15:05:14 instance-4 sshd[31177]: pam_unix(sshd:session): session opened for user pp-advent_z4sxd by (uid=0)
    Jan 25 15:05:14 instance-4 sshd[31230]: fatal: bad ownership or modes for chroot directory "/home/pp-advent_z4sxd"
    Jan 25 15:05:14 instance-4 sshd[31177]: pam_unix(sshd:session): session closed for user pp-advent_z4sxd
    Jan 25 15:06:12 instance-4 sshd[31247]: Accepted password for pp-advent_z4sxd from 115.135.25.211 port 52997 ssh2
    Jan 25 15:06:12 instance-4 sshd[31247]: pam_unix(sshd:session): session opened for user pp-advent_z4sxd by (uid=0)
    Jan 25 15:06:12 instance-4 sshd[31300]: fatal: bad ownership or modes for chroot directory "/home/pp-advent_z4sxd"
    Jan 25 15:06:12 instance-4 sshd[31247]: pam_unix(sshd:session): session closed for user pp-advent_z4sxd
    Jan 25 15:06:18 instance-4 sshd[31301]: Accepted password for pp-advent_z4sxd from 115.135.25.211 port 52999 ssh2
    Jan 25 15:06:18 instance-4 sshd[31301]: pam_unix(sshd:session): session opened for user pp-advent_z4sxd by (uid=0)
    Jan 25 15:06:18 instance-4 sshd[31354]: fatal: bad ownership or modes for chroot directory "/home/pp-advent_z4sxd"
    Jan 25 15:06:18 instance-4 sshd[31301]: pam_unix(sshd:session): session closed for user pp-advent_z4sxd
    Jan 25 15:06:23 instance-4 passwd[31358]: pam_unix(passwd:chauthtok): password changed for pp-bungee_vz9ii
    Jan 25 15:06:28 instance-4 sshd[31359]: Accepted password for pp-bungee_vz9ii from 175.140.199.241 port 59401 ssh2
    Jan 25 15:06:28 instance-4 sshd[31359]: pam_unix(sshd:session): session opened for user pp-bungee_vz9ii by (uid=0)
    Jan 25 15:06:28 instance-4 sshd[31413]: fatal: bad ownership or modes for chroot directory "/home/pp-bungee_vz9ii"
    Jan 25 15:06:28 instance-4 sshd[31359]: pam_unix(sshd:session): session closed for user pp-bungee_vz9ii
    Jan 25 15:06:34 instance-4 sshd[31414]: Accepted password for pp-bungee_vz9ii from 175.140.199.241 port 59403 ssh2
    Jan 25 15:06:34 instance-4 sshd[31414]: pam_unix(sshd:session): session opened for user pp-bungee_vz9ii by (uid=0)
    Jan 25 15:06:34 instance-4 sshd[31467]: fatal: bad ownership or modes for chroot directory "/home/pp-bungee_vz9ii"
    Jan 25 15:06:34 instance-4 sshd[31414]: pam_unix(sshd:session): session closed for user pp-bungee_vz9ii
    Jan 25 15:07:04 instance-4 sshd[31483]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=115.135.25.211 user=pp-advent_z4sxd
    Jan 25 15:07:05 instance-4 sshd[31483]: Failed password for pp-advent_z4sxd from 115.135.25.211 port 53008 ssh2
    Jan 25 15:07:05 instance-4 sshd[31483]: error: Received disconnect from 115.135.25.211: 13: Unable to authenticate [preauth]
    Jan 25 15:07:09 instance-4 passwd[31488]: pam_unix(passwd:chauthtok): password changed for pp-advent_z4sxd
    Jan 25 15:07:11 instance-4 sshd[31489]: Accepted password for pp-advent_z4sxd from 115.135.25.211 port 53015 ssh2
    Jan 25 15:07:11 instance-4 sshd[31489]: pam_unix(sshd:session): session opened for user pp-advent_z4sxd by (uid=0)
    Jan 25 15:07:11 instance-4 sshd[31542]: fatal: bad ownership or modes for chroot directory "/home/pp-advent_z4sxd"
    Jan 25 15:07:11 instance-4 sshd[31489]: pam_unix(sshd:session): session closed for user pp-advent_z4sxd
    Jan 25 15:07:17 instance-4 sshd[31543]: Accepted password for pp-advent_z4sxd from 115.135.25.211 port 53016 ssh2
    Jan 25 15:07:17 instance-4 sshd[31543]: pam_unix(sshd:session): session opened for user pp-advent_z4sxd by (uid=0)
    Jan 25 15:07:17 instance-4 sshd[31596]: fatal: bad ownership or modes for chroot directory "/home/pp-advent_z4sxd"
    Jan 25 15:07:17 instance-4 sshd[31543]: pam_unix(sshd:session): session closed for user pp-advent_z4sxd
    Jan 25 15:07:52 instance-4 sshd[31598]: Accepted password for pp-bungee_vz9ii from 175.140.199.241 port 59434 ssh2
    Jan 25 15:07:52 instance-4 sshd[31598]: pam_unix(sshd:session): session opened for user pp-bungee_vz9ii by (uid=0)
    Jan 25 15:07:52 instance-4 sshd[31651]: fatal: bad ownership or modes for chroot directory "/home/pp-bungee_vz9ii"
    Jan 25 15:07:52 instance-4 sshd[31598]: pam_unix(sshd:session): session closed for user pp-bungee_vz9ii
    Jan 25 15:07:58 instance-4 sshd[31652]: Accepted password for pp-bungee_vz9ii from 175.140.199.241 port 59436 ssh2
    Jan 25 15:07:58 instance-4 sshd[31652]: pam_unix(sshd:session): session opened for user pp-bungee_vz9ii by (uid=0)
    Jan 25 15:07:58 instance-4 sshd[31705]: fatal: bad ownership or modes for chroot directory "/home/pp-bungee_vz9ii"
    Jan 25 15:07:58 instance-4 sshd[31652]: pam_unix(sshd:session): session closed for user pp-bungee_vz9ii
    Jan 25 15:08:08 instance-4 sshd[31721]: Invalid user admin from 193.104.41.54
    Jan 25 15:08:08 instance-4 sshd[31721]: input_userauth_request: invalid user admin [preauth]



  • Ah, that error is back again. Lovely...

    Can you do the following command and print the result:
    ls -l /home | grep pp-*



  • Well, I found why it happened, and restored the 1 line that caused it to fail.

    You will need to manually fix the folders that are there, and update to the newest build that has been pushed. (The following should do that without causing harm, but have not tested)

    chown root:root /home/pp-*



  • drwxrwxrwx 5 pp-advent_d8bk4 pp-advent_d8bk4 4096 Jan 26 05:25 pp-advent_d8bk4
    drwxrwxrwx 5 pp-bungee_vz9ii pp-bungee_vz9ii 4096 Jan 25 14:00 pp-bungee_vz9ii
    drwxrwxrwx 4 pp-creati_pb0a1 pp-creati_pb0a1 4096 Jan 25 12:18 pp-creati_pb0a1
    drwxrwxrwx 4 pp-factio_h8lda pp-factio_h8lda 4096 Jan 25 12:16 pp-factio_h8lda
    drwxrwxrwx 4 pp-hubser_z1mlo pp-hubser_z1mlo 4096 Jan 25 12:19 pp-hubser_z1mlo
    drwxrwxrwx 4 pp-miniga_n8ja3 pp-miniga_n8ja3 4096 Jan 25 13:35 pp-miniga_n8ja3
    drwxrwxrwx 4 pp-skyblo_6a1r6 pp-skyblo_6a1r6 4096 Jan 25 12:17 pp-skyblo_6a1r6
    drwxrwxrwx 4 pp-skywar_kk4by pp-skywar_kk4by 4096 Jan 25 12:21 pp-skywar_kk4by



  • @leang_97

    So yeah, it's something I had changed, but thought I reverted when I realized it caused that problem.

    You need to do the following command to fix your installation home directories
    chown root:root /home/pp-*



  • Not sure if there's any update on this yet, but my Puffer Panel is on the latest version and I tried your command and I am getting the same

    fatal: bad ownership or modes for chroot directory "/home/<user>" error as the op

    OP did you find a solution?



  • @mrsal511
    This problem should be fixed on the newest version as there is one line missing for the previous. I think you should check on the file permissions



  • My panel says version 0.8.5.3 Beta Is there a newer one than that? As for scales, its on a brand new node so it should be the newest version by default.



  • Please provide the output of the following command:
    ls -l /home



  • The output of ls -l /home was:

    drwx------ 2 root root 16384 Feb 13 10:42 lost+found
    drwxrwx--- 4 root root 4096 Feb 13 12:32 pp-admin-_pv1bl
    drwxr-xr-x 4 root root 4096 Feb 13 07:52 Transfer
    -rwxr-xr-x 1 root root 6769706029 Feb 13 11:55 Transfer.zip



  • Please try the newly released version of Scales, it should fix your issue. If you need instructions on how to update Scales, please see http://scales.pufferpanel.com/docs/how-to-update-scales-to-the-latest-version



  • Updating to the latest version of scales hasn't fixed this with us either.



  • @Stigin Please make sure you are creating a new server in the panel.



  • @puffrfish

    • I am continuing this issue in my thread - but, It's interesting, After installing the auto deploy script on the node, it denies SSH putty connections from root as well as users

Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.