Console not working



  • Hey. My SRCDS console doesn't work. It's simply blank all the time. The server is running fine. Also, the Memory/CPU usage are not working too. RAM usage reports 1mb ram used and CPU usage doesn't even show. How can I fix this problems?

    Keep up the good work, I'm loving the simplicity in this panel!

    My system:

    CentOS Linux 7.3.1611
    PHP 7.1.5 (cli) (Zend Engine v3.1.0)
    MySQL/MariaDB 5.5.52
    PufferPanel 1.1.3
    Apache 2.4.6

    EDIT: one more question: how do I edit a server template AFTER server creation WITHOUT restarting the VPS?

    If I upload the edited template and start the server, it stays with the old template. After a VPS restart, it loads the new template correctly. I want to load it correctly without restarting the vps. Is it possible?

    EDIT: FIX FOR CONSOLE NOT WORKING

    You just need to open ports 5656 and 5657, both TCP.

    On CENTOS 7:

    firewall-cmd --zone=public --add-port=5656/tcp --permanent
    firewall-cmd --zone=public --add-port=5657/tcp --permanent
    firewall-cmd --reload
    


  • @bruxo00

    For your SCRDS console problem, I think I had a similar issue. I found a work-related for it: https://community.pufferpanel.com/topic/571/garrysmod-console-incredibly-slow-and-not-responsive/2

    Also, you can reload the server json configs with systemctl restart pufferd. This will restart pufferd without having to restart your entire VPS.



  • Do you wait for a while?



  • @Nystrata It already has that tty on environment. Restarting pufferd will shutdown the servers that are running?

    @haoteng10 No... Do I need to wait?

    Thanks for the replies :)



  • @bruxo00

    You're checking the json file in /var/lib/pufferd/servers, right?

    And yeah, restarting pufferd will restart all the servers currently on the panel.



  • @Nystrata
    Yes, thats right. There is no other way besides restarting pufferd?



  • @bruxo00

    Have you tried this with a non-srcds server?

    At the moment, I think it's the only way.
    I've heard that reloading individual server jsons will be implemented in a later release



  • @Nystrata
    No, right now I only need CS:GO servers.

    But the console issue, there is no other work arround or fix to this?



  • Not being able to see the console is commonly due to user misconfiguration. The only advice i can give from what you have described is to make sure that you have forwarded the correct ports, and that your node's public ip is correct.

    To attempt to diagnose your issue any further, I would need relevant logs from pufferd, as well as Pufferpanel. pufferd's logs are in /srv/pufferd/logs, and PufferPanel's logs are in /srv/pufferpanel/logs. Post them to somewhere like https://paste.ee/ and then link them.



  • @GoadingGoat what is the correct port that need to be forwarded?



  • @Jodgy your pufferd node needs port 5656 (tcp) , and 5657 (tcp) forwarded.



  • @GoadingGoat said in Console not working:

    @Jodgy your pufferd node needs port 5656 (tcp) , and 5657 (tcp) forwarded.

    -.-

    I didn't knew that.... Well, it's working now... That should be on install documentation...

    Thanks!



  • @bruxo00 Just a reminder, you should mark this thread as solved if it worked


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.