"The daemon does not report it is online, functionality is reduced until it is restarted"

  • [2017-05-21 22-50-47] Klein\Exceptions\UnhandledException: Daemon not available in /srv/pufferpanel/vendor/klein/klein/src/Klein/Klein.php:954 caused by Exception: Daemon not available in /srv/pufferpanel/src/core/daemon.php:239 @ [URL redacted]/daemon/server/22e7799c-bae9-4da2-9594-1ef48a4f80d6/logs?time=0 @@ exception--2017-05-21--22-50--e4d87a5b8d.html

    Notably, exception--2017-05-21--22-50--e4d87a5b8d.html does not seem to exist: https://i.imgur.com/exprjFH.png

  • @Wahrheit did you install the panel correctly? https://www.pufferpanel.com/docs

  • Yes. The panel has been correctly installed for some time. Ralex and I have tried to troubleshoot this in the past, but to no avail. I wanted to make a forum post to document the issue so it can be addressed eventually, and so others with the same problem can see they are not alone.

  • What is the daemon installed on?

  • Distributor ID: Ubuntu
    Description: Ubuntu 16.04.2 LTS
    Release: 16.04
    Codename: xenial

  • Have you tried changing distro?
    Have you re-installed, PufferPanel?
    Have you updated?
    Is it still not working?

  • I can't change distro at this time. Yes, the issue persisted. Yes, you saw me update. Yes, it's still not working.

  • There was probably an error when you installed Daemon or configured incorrectly.
    Best luck is to reinstall the daemon though.

  • Puffrfish tried to help me with this tonight, but is leaving it for Ralex. Curling works, but PHP can't talk to the daemon.

  • In a wholly unexpected twist of events, rebooting the VM entirely solved the issue. We still have no idea what was causing it, but things appear to be working now. Will update if that changes.

Log in to reply

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.