Spigotmc



  • Loading BuildTools version: git-BuildTools-8aa3a22-59 (#59)Git name not set, setting it to default value.
    Exception in thread "main" java.io.IOException: Cannot run program "git" (in directory "."): error=2, No such file or directory
    at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
    at org.spigotmc.builder.Builder.runProcess(Builder.java:552)
    at org.spigotmc.builder.Builder.main(Builder.java:162)
    Caused by: java.io.IOException: error=2, No such file or directory
    at java.lang.UNIXProcess.forkAndExec(Native Method)
    at java.lang.UNIXProcess.<init>(UNIXProcess.java:247)
    at java.lang.ProcessImpl.start(ProcessImpl.java:134)
    at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
    ... 2 more
    That is what i get when i try to install spigotmc :(



  • It looks like you need to install git. If using debian or ubuntu then "sudo apt-get install git" from terminal. if fedora then "sudo yum install git"



  • Well maby that should be put in the docomentry Then



  • Perhaps, but it's not an error caused by pufferpanel.

    If you read the Buildtools documentation...

    https://www.spigotmc.org/wiki/buildtools/#linux

    ...you will see that both git and java are requirements. By the same logic you could argue that installing java should be documented. Most people know that you need java to run an mc server. Maybe i'm expecting too much, but i would also assume that someone using spigot is familiar with using buildtools, and thus understands it has requirements of it's own, such as java and git. Especially seeing as Buildtools is the only legal way to obtain spigot.

    A link pointing people to the buildtools installation for spigot/craftbukkit servers would be a more appropriate solution, but i don't administrate here, and only try to help where i can.



  • Our software does attempt to install all the game dependencies before installing the daemon. This of course only works if you use the auto-deploy feature.

    We also install SRCDS dependencies which if you just run Minecraft, you will not need.


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.