Servers Not Running/Installing



  • Hey,

    So when I first installed PufferPanel everything seemed to go as planned then when I try and make my first new server I get this long repeating message of:
    "

          PUFFERPANEL STARTUP NOTICE          
    

    ==============================================

    Restarting your server now to officially start it.
    We needed to generate some server files
    before we could run this server for you.
    [ERROR] An error occured while attempting to start this server. Please ask your systems administrator to look into this.

    Running server Pre-Flight, this might take a moment or two...

    "

    Well this bummed me out and then after I stopped and try reinstalling a couple more times it gave me the same error. Then I tried and reinstall the node on my Dedicated Server and that did not work (after a reboot of my dedicated server and the webhost). Afterwards, I ran my own java startup code and it generated some files, then when I went back to the server I get another useless error that gives me "An error occurred while attempting to start this server. Please ask your systems Administrator to look into this." And this is where I am quite stumped. I'm not too sure what the problem is but I am willing to hear any answers or helpful suggestions ! :D

    Thanks,

    Peter



  • We need to see the contents of /srv/scales/logs/proc.log in order to determine what is causing the servers to not start correctly.



  • Hey sorry for the long wait and response. Here is the code from that file but I only copied the first part as its doing the same for everyother time I am trying to create a server.

    [2016-01-29 04:32:54] [INFO] + ========================================== +
    [2016-01-29 04:32:54] [INFO] | Scales logs all information, (inc. errors) |
    [2016-01-29 04:32:54] [INFO] | into the logs/ directory. Please check |
    [2016-01-29 04:32:54] [INFO] | there before asking for help with bugs. |
    [2016-01-29 04:32:54] [INFO] | |
    [2016-01-29 04:32:54] [INFO] ^[[0m| ^[[0m^[[31mSubmit bug reports at the following link: ^[[39m |
    [2016-01-29 04:32:54] [INFO] | https://github.com/PufferPanel/Scales |
    [2016-01-29 04:32:54] [INFO] + ========================================== +
    [2016-01-29 04:32:54] [VERBOSE] Using docker?: true
    [2016-01-29 04:32:54] [VERBOSE] All scripts in /lib/scripts successfully had their permissions updated.
    [2016-01-29 04:32:55] [INFO] Scales is now listening on port 5656
    [2016-01-29 04:32:55] [INFO] Scales has started
    [2016-01-29 04:32:56] [INFO] + ========================================== +
    [2016-01-29 04:32:56] [INFO] | Scales logs all information, (inc. errors) |
    [2016-01-29 04:32:56] [INFO] | into the logs/ directory. Please check |
    [2016-01-29 04:32:56] [INFO] | there before asking for help with bugs. |
    [2016-01-29 04:32:56] [INFO] | |
    [2016-01-29 04:32:56] [INFO] | Submit bug reports at the following link: |
    [2016-01-29 04:32:56] [INFO] | https://github.com/PufferPanel/Scales |
    [2016-01-29 04:32:56] [INFO] + ========================================== +
    [2016-01-29 04:32:56] [VERBOSE] Using docker?: true
    [2016-01-29 04:32:56] [VERBOSE] All scripts in /lib/scripts successfully had their permissions updated.
    [2016-01-29 04:32:56] [INFO] Scales is now listening on port 5656
    [2016-01-29 04:32:56] [INFO] Scales has started
    [2016-01-29 04:34:42] [VERBOSE] Loaded server configuration for a8afd404-cee9-4b1b-aab2-7426f6721187
    [2016-01-29 04:34:42] [VERBOSE] Starting install process
    [2016-01-29 04:34:42] [VERBOSE] Creating base config file for a8afd404-cee9-4b1b-aab2-7426f6721187
    [2016-01-29 04:34:42] [VERBOSE] Creating user pp-builds_qe4rk on the server.
    [2016-01-29 04:34:42] [ERROR] [ undefined,
    'Error occurred trying to execute a command to add a user.' ]
    Error: Command failed: /bin/sh -c ./lib/scripts/create_user.sh /home/Servers/ pp-builds_qe4rk 53D1taH2rr26ZOlO
    useradd: cannot create directory /home/Servers/pp-builds_qe4rk
    usermod: user 'pp-builds_qe4rk' does not exist
    chown: cannot access ‘/home/Servers/pp-builds_qe4rk’: No such file or directory
    chmod: cannot access ‘/home/Servers/pp-builds_qe4rk’: No such file or directory
    mkdir: cannot create directory ‘/home/Servers/pp-builds_qe4rk/public’: No such file or directory
    mkdir: cannot create directory ‘/home/Servers/pp-builds_qe4rk/backups’: No such file or directory
    chown: invalid user: ‘pp-builds_qe4rk:scalesuser’
    at ChildProcess.exithandler (child_process.js:213:12)
    at emitTwo (events.js:87:13)
    at ChildProcess.emit (events.js:172:7)
    at maybeClose (internal/child_process.js:821:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:211:5)

    Thanks.



  • You changed the home directory, which is known to actually break Scales.

    You need to remove that, and reinstall all the servers.
    You can edit the config.json, changing the "basepath" to "/home/"



  • Hey, so after I re-installed Scales it gave me this error:

    Scales@0.2.4 start /srv/scales
    ./scales start
    sh: 1: ./scales: Permission denied
    npm ERR! Linux 4.2.0-25-generic
    npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "start"
    npm ERR! node v4.2.6
    npm ERR! npm v2.14.12
    npm ERR! code ELIFECYCLE
    npm ERR! Scales@0.2.4 start: ./scales start
    npm ERR! Exit status 126
    npm ERR!
    npm ERR! Failed at the Scales@0.2.4 start script './scales start'.
    npm ERR! This is most likely a problem with the Scales package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR! ./scales start
    npm ERR! You can get their info via:
    npm ERR! npm owner ls Scales
    npm ERR! There is likely additional logging output above.
    npm ERR! Please include the following file with any support request:
    npm ERR! /srv/scales/npm-debug.log
    An error occured while installing, halting...

    Afterwards I went to /srv/scales and made all of its files and directory's chmod 777, which then scales started. Afterwards when I go back and try and make a server on the control panel I get a similar error that i stated before from the proc.log file:

    [2016-01-29 15:26:39] [INFO] + ========================================== +
    [2016-01-29 15:26:39] [INFO] | Scales logs all information, (inc. errors) |
    [2016-01-29 15:26:39] [INFO] | into the logs/ directory. Please check |
    [2016-01-29 15:26:39] [INFO] | there before asking for help with bugs. |
    [2016-01-29 15:26:39] [INFO] | |
    [2016-01-29 15:26:39] [INFO] ^[[0m| ^[[0m^[[31mSubmit bug reports at the following link: ^[[39m |
    [2016-01-29 15:26:39] [INFO] | https://github.com/PufferPanel/Scales |
    [2016-01-29 15:26:39] [INFO] + ========================================== +
    [2016-01-29 15:26:39] [VERBOSE] Using docker?: true
    [2016-01-29 15:26:39] [VERBOSE] All scripts in /lib/scripts successfully had their permissions updated.
    [2016-01-29 15:26:39] [INFO] Scales is now listening on port 5656
    [2016-01-29 15:26:40] [INFO] Scales has started
    [2016-01-29 15:26:40] [INFO] + ========================================== +
    [2016-01-29 15:26:40] [INFO] | Scales logs all information, (inc. errors) |
    [2016-01-29 15:26:40] [INFO] | into the logs/ directory. Please check |
    [2016-01-29 15:26:40] [INFO] | there before asking for help with bugs. |
    [2016-01-29 15:26:40] [INFO] | |
    [2016-01-29 15:26:40] [INFO] | Submit bug reports at the following link: |
    [2016-01-29 15:26:40] [INFO] | https://github.com/PufferPanel/Scales |
    [2016-01-29 15:26:40] [INFO] + ========================================== +
    [2016-01-29 15:26:40] [VERBOSE] Using docker?: true
    [2016-01-29 15:26:40] [VERBOSE] All scripts in /lib/scripts successfully had their permissions updated.
    [2016-01-29 15:26:40] [INFO] Scales is now listening on port 5656
    [2016-01-29 15:26:41] [INFO] Scales has started
    [2016-01-29 15:26:41] [ERROR] uncaughtException: EACCES: permission denied, open '/srv/scales/scales.pid'
    [2016-01-29 15:26:41] [ERROR] Unhandled exception occurred
    Error: EACCES: permission denied, open '/srv/scales/scales.pid'
    at Error (native)
    at Object.fs.openSync (fs.js:549:18)
    at Object.fs.writeFileSync (fs.js:1156:15)
    at wait [as _onTimeout] (/srv/scales/index.js:46:16)
    at Timer.listOnTimeout (timers.js:92:15)
    [2016-01-29 15:27:07] [VERBOSE] Loaded server configuration for aff21928-fb65-41ad-abea-22a4e504c052
    [2016-01-29 15:27:07] [VERBOSE] Starting install process
    [2016-01-29 15:27:07] [VERBOSE] Creating base config file for aff21928-fb65-41ad-abea-22a4e504c052
    [2016-01-29 15:27:07] [VERBOSE] Creating user pp-builds_d0zfl on the server.
    [2016-01-29 15:27:07] [ERROR] [ undefined,
    'Error occurred trying to execute a command to add a user.' ]
    Error: Command failed: /bin/sh -c ./lib/scripts/create_user.sh /home/ pp-builds_d0zfl 9AEWNmffPF5hKZ52
    useradd: Permission denied.
    useradd: cannot lock /etc/passwd; try again later.
    usermod: user 'pp-builds_d0zfl' does not exist
    chown: cannot access ‘/home/pp-builds_d0zfl’: No such file or directory
    chmod: cannot access ‘/home/pp-builds_d0zfl’: No such file or directory
    mkdir: cannot create directory ‘/home/pp-builds_d0zfl/public’: No such file or directory
    mkdir: cannot create directory ‘/home/pp-builds_d0zfl/backups’: No such file or directory
    chown: invalid user: ‘pp-builds_d0zfl:scalesuser’
    at ChildProcess.exithandler (child_process.js:213:12)
    at emitTwo (events.js:87:13)
    at ChildProcess.emit (events.js:172:7)
    at maybeClose (internal/child_process.js:821:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:211:5)

    Im not too sure what I do now after I already tried to reconfigure it with /home/

    Thanks.



  • Scales has to run as root, which is what those later errors suggest, because it cannot write anywhere (this is a problem we are looking to fix, because we don't really need root for something like this I hope)

    And do not use 777. Copy the config out, reinstall the node by redownloading and extracting, and put the config contents back (do not directly copy the file so the perms are not altered). Then use
    chmod +x scales

    That will resolve your permission problem for the ./scales command.



  • So when I install using the auto-generated script should I run that script as root or as a sudoer ?



  • Both achieve the same result. It is when you start scales that you need to do so using either sudo or root (we assumed you were using a root user when running Scales, we will update our documentation)



  • Thank You for your help this solved my problem! But now im not too sure about this error when I used the bulid perameter -p spigot:

    installer:~$ rm -rf *
    installer:~$ curl -o BuildTools.jar https://hub.spigotmc.org/jenkins/job/BuildTools/lastSuccessfulBuild/artifact/target/BuildTools.jar
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed

    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 3331k 100 3331k 0 0 6079k 0 --:--:-- --:--:-- --:--:-- 6090k
    installer:~$ git config --global --unset core.autocrlf
    error: could not lock config file /home/pp-builds_p6tbe/.gitconfig: Permission denied
    installer:~$ java -jar BuildTools.jar
    Loading BuildTools version: git-BuildTools-5861ac0-46 (#46)
    Git name not set, setting it to default value.
    error: could not lock config file /home/pp-builds_p6tbe/.gitconfig: Permission denied
    Exception in thread "main" java.lang.RuntimeException: Error running command, return status !=0: [git, config, --global, user.name, BuildTools]
    at org.spigotmc.builder.Builder.runProcess(Builder.java:535)
    at org.spigotmc.builder.Builder.main(Builder.java:154)
    An error occurred while installing.
    error: unable to contact remote service to alert to completed install process.

    Thanks for the great help!



  • And in the log file it says this:

    Git name not set, setting it to default value.
    error: could not lock config file /home/pp-builds_p6tbe/.gitconfig: Permission denied
    Exception in thread "main" java.lang.RuntimeException: Error running command, return status !=0: [git, config, --global, user.name, BuildTools]
    at org.spigotmc.builder.Builder.runProcess(Builder.java:535)
    at org.spigotmc.builder.Builder.main(Builder.java:154)

    Thanks for the great help!



  • Can you provide the log from Scales? That error does not seem to make sense, and suggests something has improperly failed.

    Can you also please update to PufferPanel 0.8.5.2 and Scales 0.2.4.1 which introduce some fixes
    https://github.com/PufferPanel/PufferPanel/releases/download/v0.8.5.2/pufferpanel.tar.gz
    https://github.com/PufferPanel/Scales/archive/0.2.4.1.tar.gz



  • Okay, I updated PufferPanel and Scales and here is the log files from the proc.log and 1 of the installer logs:

    proc.log:

    [2016-01-29 22:38:45] [INFO] + ========================================== +
    [2016-01-29 22:38:45] [INFO] | Scales logs all information, (inc. errors) |
    [2016-01-29 22:38:45] [INFO] | into the logs/ directory. Please check |
    [2016-01-29 22:38:45] [INFO] | there before asking for help with bugs. |
    [2016-01-29 22:38:45] [INFO] | |
    [2016-01-29 22:38:45] [INFO] ^[[0m| ^[[0m^[[31mSubmit bug reports at the following link: ^[[39m |
    [2016-01-29 22:38:45] [INFO] | https://github.com/PufferPanel/Scales |
    [2016-01-29 22:38:45] [INFO] + ========================================== +
    [2016-01-29 22:38:45] [VERBOSE] Using docker?: true
    [2016-01-29 22:38:45] [VERBOSE] All scripts in /lib/scripts successfully had their permissions updated.
    [2016-01-29 22:38:46] [INFO] Scales is now listening on port 5656
    [2016-01-29 22:38:46] [INFO] Scales has started
    [2016-01-29 22:38:46] [INFO] + ========================================== +
    [2016-01-29 22:38:46] [INFO] | Scales logs all information, (inc. errors) |
    [2016-01-29 22:38:46] [INFO] | into the logs/ directory. Please check |
    [2016-01-29 22:38:46] [INFO] | there before asking for help with bugs. |
    [2016-01-29 22:38:46] [INFO] | |
    [2016-01-29 22:38:46] [INFO] | Submit bug reports at the following link: |
    [2016-01-29 22:38:46] [INFO] | https://github.com/PufferPanel/Scales |
    [2016-01-29 22:38:46] [INFO] + ========================================== +
    [2016-01-29 22:38:46] [VERBOSE] Using docker?: true
    [2016-01-29 22:38:46] [VERBOSE] All scripts in /lib/scripts successfully had their permissions updated.
    [2016-01-29 22:38:47] [INFO] Scales is now listening on port 5656
    [2016-01-29 22:38:47] [INFO] Scales has started
    [2016-01-29 22:39:24] [VERBOSE] Loaded server configuration for dda46a1b-7bc1-42cd-86e3-743429daa752
    [2016-01-29 22:39:24] [VERBOSE] Starting install process
    [2016-01-29 22:39:24] [VERBOSE] Creating base config file for dda46a1b-7bc1-42cd-86e3-743429daa752
    [2016-01-29 22:39:24] [VERBOSE] Creating user pp-builds_yx0sv on the server.
    [2016-01-29 22:39:24] [VERBOSE] Finished basic install process for new server, preparing to complete full install process.
    [2016-01-29 22:39:24] [VERBOSE] Starting full install process
    [2016-01-29 22:39:24] [VERBOSE] Creating docker container for server dda46a1b-7bc1-42cd-86e3-743429daa752
    [2016-01-29 22:39:24] [VERBOSE] Executing cmd: docker create -it --name pp-builds_yx0sv -h docker -m 4096M --blkio-weight=500 -p 173.255.117.176:25565:25565 -p 173.255.117.176:25565:25565/udp -u 1003 -v /Servers/pp-builds_yx0sv/public:/hom$
    [2016-01-29 22:39:24] [VERBOSE] Successfully added a new docker container for dda46a1b-7bc1-42cd-86e3-743429daa752.
    [2016-01-29 22:39:24] [VERBOSE] Running major installer process for dda46a1b-7bc1-42cd-86e3-743429daa752 which could take a few minutes to complete. Do not stop Scales during this process.
    [2016-01-29 22:39:24] [VERBOSE] Executing su -s /bin/bash -l pp-builds_yx0sv -c /srv/scales/lib/scripts/install/minecraft.sh -d -b /Servers/ -u pp-builds_yx0sv -p spigot
    [2016-01-29 22:39:29] [VERBOSE] installer:~$ rm -rf *
    [2016-01-29 22:39:29] [VERBOSE] installer:~$ curl -o BuildTools.jar https://hub.spigotmc.org/jenkins/job/BuildTools/lastSuccessfulBuild/artifact/target/BuildTools.jar
    [2016-01-29 22:39:29] [VERBOSE] % Total
    [2016-01-29 22:39:29] [VERBOSE] % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- --:$
    [2016-01-29 22:39:29] [VERBOSE] 0 0 0 0 0 0
    [2016-01-29 22:39:29] [VERBOSE] 0 0 --:--:-- --:--:-- --:--:-- 0
    [2016-01-29 22:39:29] [VERBOSE] 100 3331k 100 3331k 0 0 690
    [2016-01-29 22:39:29] [VERBOSE] 8k 0 --:--:-- --:--:-- --:--:-- 6897k
    [2016-01-29 22:39:29] [VERBOSE] installer:~$ git config --global --unset core.autocrlf
    [2016-01-29 22:39:29] [VERBOSE] error: could not lock config file /home/pp-builds_yx0sv/.gitconfig: Permission denied
    [2016-01-29 22:39:29] [VERBOSE] installer:~$ java -jar BuildTools.jar
    [2016-01-29 22:39:30] [VERBOSE] Loading BuildTools version: git-BuildTools-5861ac0-46 (#46)
    [2016-01-29 22:39:30] [VERBOSE] Git name not set, setting it to default value.
    [2016-01-29 22:39:30] [VERBOSE]
    [2016-01-29 22:39:30] [VERBOSE] Exception in thread "main"
    [2016-01-29 22:39:30] [VERBOSE] java.lang.RuntimeException: Error running command, return status !=0: [git, config, --global, user.name, BuildTools]
    [2016-01-29 22:39:30] [VERBOSE] at org.spigotmc.builder.Builder.runProcess(Builder.java:535) at org.spigotmc.builder.Builder.main(Builder.java:154)
    [2016-01-29 22:39:30] [VERBOSE] error: could not lock config file /home/pp-builds_yx0sv/.gitconfig: Permission denied
    [2016-01-29 22:39:30] [VERBOSE] An error occurred while installing.
    [2016-01-29 22:39:30] [ERROR] Unable to complete the installer process. Please check the logs for more information.
    Error: An error was encountered with the installer script for dda46a1b-7bc1-42cd-86e3-743429daa752. Script edited with code 1 and was logged to ./logs/installer/dda46a1b-7bc1-42cd-86e3-743429daa752-2016.01.29.22.39.24.log
    at Socket.<anonymous> (/srv/scales/lib/process.js:832:37)
    at emitTwo (events.js:87:13)
    at Socket.emit (events.js:172:7)
    at Terminal.emit (/srv/scales/node_modules/pty.js/lib/pty.js:306:27)
    at onexit (/srv/scales/node_modules/pty.js/lib/pty.js:118:10)

    Installer Log: (/logs/installer/dda46a1b-7bc1-42cd-86e3-743429daa752-2016.01.29.22.39.24.log)

    installer:~$ rm -rf *
    installer:~$ curl -o BuildTools.jar https://hub.spigotmc.org/jenkins/job/BuildTools/lastSuccessfulBuild/artifact/target/BuildTools.jar
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 3331k 100 3331k 0 0 6908k 0 --:--:-- --:--:-- --:--:-- 6897k
    installer:~$ git config --global --unset core.autocrlf
    error: could not lock config file /home/pp-builds_yx0sv/.gitconfig: Permission denied
    installer:~$ java -jar BuildTools.jar
    Loading BuildTools version: git-BuildTools-5861ac0-46 (#46)
    Git name not set, setting it to default value.
    Exception in thread "main" java.lang.RuntimeException: Error running command, return status !=0: [git, config, --global, user.name, BuildTools]
    at org.spigotmc.builder.Builder.runProcess(Builder.java:535)
    at org.spigotmc.builder.Builder.main(Builder.java:154)
    error: could not lock config file /Servers/pp-builds_yx0sv/.gitconfig: Permission denied
    An error occurred while installing.
    === Script exited with code 1 ===

    Thanks for the Help! :D



  • The root directory for Scales has changed (you have it defined as /Servers/), and Scales does not properly handle this. You need to reinstall the node, and not change the base path for Scales. (If you install the latest versions of the panel, that will not occur)



  • I have tried Both with a custom directory and with the /home/ directory and it gives me the same error, I'm pretty confident that its not that.
    And I do run the latest Pufferpanel and Scales.

    Thanks!



  • However, when do a completely new install on a fresh Ubuntu server (Re-Installed Ubuntu Server) I get the following error when I go and try to create a Minecraft Server:

    proc.log:

    [2016-01-30 18:56:26] [INFO] + ========================================== +
    [2016-01-30 18:56:26] [INFO] | Scales logs all information, (inc. errors) |
    [2016-01-30 18:56:26] [INFO] | into the logs/ directory. Please check |
    [2016-01-30 18:56:26] [INFO] | there before asking for help with bugs. |
    [2016-01-30 18:56:26] [INFO] | |
    [2016-01-30 18:56:26] [INFO] ^[[0m| ^[[0m^[[31mSubmit bug reports at the following link: ^[[39m |
    [2016-01-30 18:56:26] [INFO] | https://github.com/PufferPanel/Scales |
    [2016-01-30 18:56:26] [INFO] + ========================================== +
    [2016-01-30 18:56:26] [VERBOSE] Using docker?: true
    [2016-01-30 18:56:26] [VERBOSE] All scripts in /lib/scripts successfully had their permissions updated.
    [2016-01-30 18:56:27] [INFO] Scales is now listening on port 5656
    [2016-01-30 18:56:27] [INFO] Scales has started
    [2016-01-30 18:56:27] [INFO] + ========================================== +
    [2016-01-30 18:56:27] [INFO] | Scales logs all information, (inc. errors) |
    [2016-01-30 18:56:27] [INFO] | into the logs/ directory. Please check |
    [2016-01-30 18:56:27] [INFO] | there before asking for help with bugs. |
    [2016-01-30 18:56:27] [INFO] | |
    [2016-01-30 18:56:27] [INFO] | Submit bug reports at the following link: |
    [2016-01-30 18:56:27] [INFO] | https://github.com/PufferPanel/Scales |
    [2016-01-30 18:56:27] [INFO] + ========================================== +
    [2016-01-30 18:56:27] [VERBOSE] Using docker?: true
    [2016-01-30 18:56:27] [VERBOSE] All scripts in /lib/scripts successfully had their permissions updated.
    [2016-01-30 18:56:28] [INFO] Scales is now listening on port 5656
    [2016-01-30 18:56:28] [INFO] Scales has started
    [2016-01-30 18:57:12] [VERBOSE] Loaded server configuration for 9bb44155-8d8d-49f5-96fc-0ae48ab2b816
    [2016-01-30 18:57:12] [VERBOSE] Starting install process
    [2016-01-30 18:57:12] [VERBOSE] Creating base config file for 9bb44155-8d8d-49f5-96fc-0ae48ab2b816
    [2016-01-30 18:57:12] [VERBOSE] Creating user pp-builds_n4ijt on the server.
    [2016-01-30 18:57:12] [VERBOSE] Finished basic install process for new server, preparing to complete full install process.
    [2016-01-30 18:57:12] [VERBOSE] Starting full install process
    [2016-01-30 18:57:12] [VERBOSE] Creating docker container for server 9bb44155-8d8d-49f5-96fc-0ae48ab2b816
    [2016-01-30 18:57:12] [VERBOSE] Executing cmd: docker create -it --name pp-builds_n4ijt -h docker -m 4096M --blkio-weight=500 -p 173.255.117.176:25565:25565 -p 173.255.117.176:25565:25565/udp -u 1001 -v /home/pp-builds_n4ijt/public:/home/c$
    [2016-01-30 18:57:39] [VERBOSE] Successfully added a new docker container for 9bb44155-8d8d-49f5-96fc-0ae48ab2b816.
    [2016-01-30 18:57:39] [VERBOSE] Running major installer process for 9bb44155-8d8d-49f5-96fc-0ae48ab2b816 which could take a few minutes to complete. Do not stop Scales during this process.
    [2016-01-30 18:57:39] [VERBOSE] Executing su -s /bin/bash -l pp-builds_n4ijt -c /srv/scales/lib/scripts/install/minecraft.sh -d -b /home -u pp-builds_n4ijt -p spigot
    [2016-01-30 18:57:44] [VERBOSE] The home directory for the user (/home/pp-builds_n4ijt/public) does not exist on the system.
    [2016-01-30 18:57:44] [ERROR] Unable to complete the installer process. Please check the logs for more information.
    Error: An error was encountered with the installer script for 9bb44155-8d8d-49f5-96fc-0ae48ab2b816. Script edited with code 1 and was logged to ./logs/installer/9bb44155-8d8d-49f5-96fc-0ae48ab2b816-2016.01.30.18.57.39.log
    at Socket.<anonymous> (/srv/scales/lib/process.js:832:37)
    at emitTwo (events.js:87:13)
    at Socket.emit (events.js:172:7)
    at Terminal.emit (/srv/scales/node_modules/pty.js/lib/pty.js:306:27)
    at onexit (/srv/scales/node_modules/pty.js/lib/pty.js:118:10)

    And in the Install Log file:

    The home directory for the user (/home/pp-builds_n4ijt/public) does not exist on the system.
    === Script exited with code 1 ===

    This is on a fresh server setup with Scales, Im not too sure what is causing this.

    Thanks for the Great support! :D



  • Is there a possible fix for this issue?



  • We have released a new version of PufferPanel and Scales with an improved installation process and many bug fixes. Please try the latest version and see if it fixes your issues.

    I’m marking this question as solved since there has been a long period of inactivity on it. If you are still experiencing issues, please create a new question. Thanks!



Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.