error 500



  • When i go to my website to see the Panel, I get this error:Server Error

    We're sorry! The server encountered an internal error and was unable to complete your request. Please try again later.

    error 500

    And also when i was making the panel i got this error ERROR 1062 (23000) at line 2: Duplicate entry 'LocalNode' for key 'name'

    I am on centos 7
    ty



  • Did you do an update or a fresh installation?

    Can you please provide the full logs from the installer and the exceptions.log file from /srv/pufferpanel/logs



  • it was a fresh installation

    Here is the log file

    [2017-04-29 00-52-00] Parse Error: syntax error, unexpected 'finally' (T_STRING), expecting catch (T_CATCH) in /srv/pufferpanel/vendor/twig/twig/lib/Twig/Environment.php:412 @ http://193.70.90.178/ @@ exception--2017-04-29--00-52--706e7ec4a5.html
    [2017-04-29 00-57-12] Parse Error: syntax error, unexpected 'finally' (T_STRING), expecting catch (T_CATCH) in /srv/pufferpanel/vendor/twig/twig/lib/Twig/Environment.php:412 @ http://193.70.90.178/index @@ exception--2017-04-29--00-52--706e7ec4a5.html
    [2017-04-29 01-38-15] Parse Error: syntax error, unexpected 'finally' (T_STRING), expecting catch (T_CATCH) in /srv/pufferpanel/vendor/twig/twig/lib/Twig/Environment.php:412 @ http://193.70.90.178/sky.php @@ exception--2017-04-29--00-52--706e7ec4a5.html
    [2017-04-29 01-38-16] Parse Error: syntax error, unexpected 'finally' (T_STRING), expecting catch (T_CATCH) in /srv/pufferpanel/vendor/twig/twig/lib/Twig/Environment.php:412 @ http://193.70.90.178/favicon.ico @@ exception--2017-04-29--00-52--706e7ec4a5.html



  • What version of PHP are you using?



  • Here

    Package php-5.4.16-42.el7.x86_64 already installed and latest version
    Package php-mysql-5.4.16-42.el7.x86_64 already installed and latest version
    Package php-devel-5.4.16-42.el7.x86_64 already installed and latest version
    Package php-gd-5.4.16-42.el7.x86_64 already installed and latest version
    Package php-pecl-memcache-3.0.8-4.el7.x86_64 already installed and latest version
    Package php-pspell-5.4.16-42.el7.x86_64 already installed and latest version
    Package php-snmp-5.4.16-42.el7.x86_64 already installed and latest version
    Package php-xmlrpc-5.4.16-42.el7.x86_64 already installed and latest version
    Package php-xml-5.4.16-42.el7.x86_64 already installed and latest version
    Nothing to do



  • You have 5.4 installed, which is not supported.

    You need 5.5+ installed.



  • How do install PHP 5.5+ On centos 7



  • https://www.pufferpanel.com/docs/getting-started

    Due to many variations within CentOS for installing PHP 5.5+,
    we do not have acceptable documentation for installing it.
    Please consult guides on how to install PHP 5.5 and
    nginx for your specific CentOS version.

    https://www.digitalocean.com/community/tutorials/how-to-install-linux-nginx-mysql-php-lemp-stack-on-centos-7

    Example instructions
    sudo rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
    sudo rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm

    sudo yum install nginx mariadb-server mariadb php56w-fpm php56w-common php56w-cli php56w-mcrypt php56w-pdo php56w-mysqlnd

    sudo systemctl start nginx
    sudo systemctl enable nginx

    sudo systemctl enable mariadb
    sudo systemctl start mariadb

    sudo systemctl start php-fpm
    sudo systemctl enable php-fpm



  • Done But Now it say This site can’t be reached


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.