Welcome to the PufferPanel community forums! If you need help please register an account and post in the Support category.

Issues getting started with pufferpanel



  • Since I'm not able to help you since it looks like it don't log the error, I would try to uninstall anything and install it again inside docker (the purpose of docker is to help to get out from situations like this :P )



  • @GoadingGoat said in Issues getting started with pufferpanel:

    Thanks for trying.

    There should be even a PufferPanel docker image already online :P



  • The issue is that the php user cannot write to the /srv/pufferpanel/logs directory.

    Just chown that folder to your php user (www-data if ubuntu, apache if centos, can use htop to determine which).



  • Unfortunately not that either.



  • When you fix that issue, it will allow the actual logs to exist in /srv/pufferpanel/logs.

    Please provide those.



  • oh, i see...

    Thanks

    error is this:
    [2017-03-30 21-20-29] PDOException: SQLSTATE[HY000] [1045] Access denied for user 'pufferpanel'@'localhost' (using password: YES) #1045 in /srv/pufferpanel/vendor/j4mie/idiorm/idiorm.php:254 @ http://192.168.177.204:81$

    Rather strange.... as pufferpanel has full permissions over its database.

    where are the credentials for accessing the database stored?



  • This is stored in the config, located at /srv/pufferpanel/config.json



  • Thanks, i think that's fixed now.

    Have a new error now.

    [2017-03-30 21-40-02] Exception: Unable to load the required language file! /srv/pufferpanel/app/languages/.json in /srv/pufferpanel/src/core/language.php:49 @ http://192.168.177.204:81/ @@ exception--2017-03-30--21-40--6a18fe2dcf.html

    There isn't a languages folder there.



  • This implies the original installer had issues updating the database correctly.

    You can run the following command to resolve the database issue bit:
    ./pufferpanel updatesite

    That will fix the database settings so that you have a default language.

    As for the languages folder, you are saying /srv/pufferpanel/app/languages is empty?



  • actually wait... the folder is there. I misread the path.

    and updating the site seems to have fixed everything.

    Thank you very much


Log in to reply
 

6
Online

944
Users

922
Topics

3.7k
Posts