Welcome to the PufferPanel community forums! Please visit our discord for support: https://discord.gg/v8dz49e

Issues getting started with pufferpanel



  • Updated again,
    version is: pufferd v1.0.5 (2017-02-09_06:49:32PM 17ef2d96cd8a73910a1a6bb94d7227927f02fe48)

    and this if my php7.0-fpm log from /var/log/php7.0-fpm.log

    [0_1490858426817_php7.0-fpm.log](Uploading 100%)

    edit (don't have enough privileges for .log extension)
    here it is:
    [26-Mar-2017 07:35:02] NOTICE: error log file re-opened
    [28-Mar-2017 15:51:28] NOTICE: fpm is running, pid 918
    [28-Mar-2017 15:51:28] NOTICE: ready to handle connections
    [28-Mar-2017 15:51:28] NOTICE: systemd monitor interval set to 10000ms
    [30-Mar-2017 13:40:16] NOTICE: Terminating ...
    [30-Mar-2017 13:40:16] NOTICE: exiting, bye-bye!
    [30-Mar-2017 13:40:16] NOTICE: fpm is running, pid 15801
    [30-Mar-2017 13:40:16] NOTICE: ready to handle connections
    [30-Mar-2017 13:40:16] NOTICE: systemd monitor interval set to 10000ms
    [30-Mar-2017 13:54:11] NOTICE: Terminating ...
    [30-Mar-2017 13:54:11] NOTICE: exiting, bye-bye!
    [30-Mar-2017 13:54:11] NOTICE: fpm is running, pid 16006
    [30-Mar-2017 13:54:11] NOTICE: ready to handle connections
    [30-Mar-2017 13:54:11] NOTICE: systemd monitor interval set to 10000ms
    [30-Mar-2017 13:55:54] NOTICE: Terminating ...
    [30-Mar-2017 13:55:54] NOTICE: exiting, bye-bye!
    [30-Mar-2017 13:55:54] NOTICE: fpm is running, pid 16168
    [30-Mar-2017 13:55:54] NOTICE: ready to handle connections
    [30-Mar-2017 13:55:54] NOTICE: systemd monitor interval set to 10000ms
    [30-Mar-2017 14:22:26] NOTICE: Terminating ...
    [30-Mar-2017 14:22:26] NOTICE: exiting, bye-bye!
    [30-Mar-2017 14:22:26] NOTICE: fpm is running, pid 16674
    [30-Mar-2017 14:22:26] NOTICE: ready to handle connections
    [30-Mar-2017 14:22:26] NOTICE: systemd monitor interval set to 10000ms
    [30-Mar-2017 14:46:13] NOTICE: Terminating ...
    [30-Mar-2017 14:46:13] NOTICE: exiting, bye-bye!
    [30-Mar-2017 14:46:13] NOTICE: fpm is running, pid 17534
    [30-Mar-2017 14:46:13] NOTICE: ready to handle connections
    [30-Mar-2017 14:46:13] NOTICE: systemd monitor interval set to 10000ms
    [30-Mar-2017 14:53:53] NOTICE: Terminating ...
    [30-Mar-2017 14:53:53] NOTICE: exiting, bye-bye!
    [30-Mar-2017 14:53:53] NOTICE: fpm is running, pid 17657
    [30-Mar-2017 14:53:53] NOTICE: ready to handle connections
    [30-Mar-2017 14:53:53] NOTICE: systemd monitor interval set to 10000ms



  • This is the php-fpm log, not the error log



  • To read the php error you need to read the nginx error file

    If you don't find it or it don't exist add this to the nginx config:
    error_log /var/log/nginx/pufferd.error.log error;



  • where is it's error log normally? struggling to find it.



  • @GoadingGoat usually /var/log/nginx/error.log
    (I could be wrong with the exact path since I'm writing from a mobile device)



  • so i have added "error_log /var/log/nginx/pufferd.error.log error;" into the nginx config, restarted nginx and pufferd and there are still no errors.

    and yes that path is correct



  • @GoadingGoat okay, maybe it's a warn, try to remove the "error" word (the last one)



  • nothing... not in the /var/log/nginx/pufferd.error.log file or /var/log/nginx/error.log



  • If it don't work I'm sorry but I don't know what to do...
    Without a error reference I can't figure out what don't work in your version...



  • Thanks for trying.



  • Since I'm not able to help you since it looks like it don't log the error, I would try to uninstall anything and install it again inside docker (the purpose of docker is to help to get out from situations like this :P )



  • @GoadingGoat said in Issues getting started with pufferpanel:

    Thanks for trying.

    There should be even a PufferPanel docker image already online :P



  • The issue is that the php user cannot write to the /srv/pufferpanel/logs directory.

    Just chown that folder to your php user (www-data if ubuntu, apache if centos, can use htop to determine which).



  • Unfortunately not that either.



  • When you fix that issue, it will allow the actual logs to exist in /srv/pufferpanel/logs.

    Please provide those.



  • oh, i see...

    Thanks

    error is this:
    [2017-03-30 21-20-29] PDOException: SQLSTATE[HY000] [1045] Access denied for user 'pufferpanel'@'localhost' (using password: YES) #1045 in /srv/pufferpanel/vendor/j4mie/idiorm/idiorm.php:254 @ http://192.168.177.204:81$

    Rather strange.... as pufferpanel has full permissions over its database.

    where are the credentials for accessing the database stored?



  • This is stored in the config, located at /srv/pufferpanel/config.json



  • Thanks, i think that's fixed now.

    Have a new error now.

    [2017-03-30 21-40-02] Exception: Unable to load the required language file! /srv/pufferpanel/app/languages/.json in /srv/pufferpanel/src/core/language.php:49 @ http://192.168.177.204:81/ @@ exception--2017-03-30--21-40--6a18fe2dcf.html

    There isn't a languages folder there.



  • This implies the original installer had issues updating the database correctly.

    You can run the following command to resolve the database issue bit:
    ./pufferpanel updatesite

    That will fix the database settings so that you have a default language.

    As for the languages folder, you are saying /srv/pufferpanel/app/languages is empty?



  • actually wait... the folder is there. I misread the path.

    and updating the site seems to have fixed everything.

    Thank you very much


Log in to reply
 

4
Online

1.1k
Users

946
Topics

3.8k
Posts