Issues getting started with pufferpanel



  • Getting this:
    0_1490845689661_error.PNG

    pufferpanel installed correctly, and the database has tables initialised in it, although only one entry.
    0_1490845956323_database overview.PNG
    Locations table entry:
    0_1490845984317_locations table.PNG

    Was expecting more entries after setup tbh...

    and here is my nginx config for pufferpanel:

    0_1490848027125_Capture.PNG )
    No errors are being generated in the nginx error log.
    And pufferd is running:
    0_1490846267017_pufferd status.PNG

    Really stumped... (assuming nginx config error though)
    OS: debian stretch
    webserver: nginx
    php: php7.0



  • I doubt it's a nginx error...
    Anyway if you think so you can check the error log file..
    I suggest instead to look at the php-fpm error file instead....
    You could attach both of them in a message if you want



  • php-fpm has no errors in it's log, and neither does the nginx error log.



  • Well, usually the 50x errors are logged....
    Anyway the first thing I suggest you to do is to update pufferd



  • Have already done that as well.



  • @GoadingGoat can you show me the log now?



  • To be more precise, i should have said i updated pufferd 3 hours ago.
    Hence logs will still be the same.
    Can try updating again if you think it would help though.



  • @GoadingGoat (I told it 'cause the pufferd screen you attached is the old version)



  • Anyway I doubt that there's no error in the PHP log...
    Can you check again?



  • Updated again,
    version is: pufferd v1.0.5 (2017-02-09_06:49:32PM 17ef2d96cd8a73910a1a6bb94d7227927f02fe48)

    and this if my php7.0-fpm log from /var/log/php7.0-fpm.log

    [0_1490858426817_php7.0-fpm.log](Uploading 100%)

    edit (don't have enough privileges for .log extension)
    here it is:
    [26-Mar-2017 07:35:02] NOTICE: error log file re-opened
    [28-Mar-2017 15:51:28] NOTICE: fpm is running, pid 918
    [28-Mar-2017 15:51:28] NOTICE: ready to handle connections
    [28-Mar-2017 15:51:28] NOTICE: systemd monitor interval set to 10000ms
    [30-Mar-2017 13:40:16] NOTICE: Terminating ...
    [30-Mar-2017 13:40:16] NOTICE: exiting, bye-bye!
    [30-Mar-2017 13:40:16] NOTICE: fpm is running, pid 15801
    [30-Mar-2017 13:40:16] NOTICE: ready to handle connections
    [30-Mar-2017 13:40:16] NOTICE: systemd monitor interval set to 10000ms
    [30-Mar-2017 13:54:11] NOTICE: Terminating ...
    [30-Mar-2017 13:54:11] NOTICE: exiting, bye-bye!
    [30-Mar-2017 13:54:11] NOTICE: fpm is running, pid 16006
    [30-Mar-2017 13:54:11] NOTICE: ready to handle connections
    [30-Mar-2017 13:54:11] NOTICE: systemd monitor interval set to 10000ms
    [30-Mar-2017 13:55:54] NOTICE: Terminating ...
    [30-Mar-2017 13:55:54] NOTICE: exiting, bye-bye!
    [30-Mar-2017 13:55:54] NOTICE: fpm is running, pid 16168
    [30-Mar-2017 13:55:54] NOTICE: ready to handle connections
    [30-Mar-2017 13:55:54] NOTICE: systemd monitor interval set to 10000ms
    [30-Mar-2017 14:22:26] NOTICE: Terminating ...
    [30-Mar-2017 14:22:26] NOTICE: exiting, bye-bye!
    [30-Mar-2017 14:22:26] NOTICE: fpm is running, pid 16674
    [30-Mar-2017 14:22:26] NOTICE: ready to handle connections
    [30-Mar-2017 14:22:26] NOTICE: systemd monitor interval set to 10000ms
    [30-Mar-2017 14:46:13] NOTICE: Terminating ...
    [30-Mar-2017 14:46:13] NOTICE: exiting, bye-bye!
    [30-Mar-2017 14:46:13] NOTICE: fpm is running, pid 17534
    [30-Mar-2017 14:46:13] NOTICE: ready to handle connections
    [30-Mar-2017 14:46:13] NOTICE: systemd monitor interval set to 10000ms
    [30-Mar-2017 14:53:53] NOTICE: Terminating ...
    [30-Mar-2017 14:53:53] NOTICE: exiting, bye-bye!
    [30-Mar-2017 14:53:53] NOTICE: fpm is running, pid 17657
    [30-Mar-2017 14:53:53] NOTICE: ready to handle connections
    [30-Mar-2017 14:53:53] NOTICE: systemd monitor interval set to 10000ms



  • This is the php-fpm log, not the error log



  • To read the php error you need to read the nginx error file

    If you don't find it or it don't exist add this to the nginx config:
    error_log /var/log/nginx/pufferd.error.log error;



  • where is it's error log normally? struggling to find it.



  • @GoadingGoat usually /var/log/nginx/error.log
    (I could be wrong with the exact path since I'm writing from a mobile device)



  • so i have added "error_log /var/log/nginx/pufferd.error.log error;" into the nginx config, restarted nginx and pufferd and there are still no errors.

    and yes that path is correct



  • @GoadingGoat okay, maybe it's a warn, try to remove the "error" word (the last one)



  • nothing... not in the /var/log/nginx/pufferd.error.log file or /var/log/nginx/error.log



  • If it don't work I'm sorry but I don't know what to do...
    Without a error reference I can't figure out what don't work in your version...



  • Thanks for trying.



  • Since I'm not able to help you since it looks like it don't log the error, I would try to uninstall anything and install it again inside docker (the purpose of docker is to help to get out from situations like this :P )


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.