Welcome to the PufferPanel community forums! If you need help please register an account and post in the Support category.

Error enabling pufferd service

  • While trying to create a new server, I get an error "Daemon not available"
    And in pufferd logs:

    [03:00:03] [ERROR] Error enabling pufferd service
    exec: "systemctl": executable file not found in $PATH

    Using Ubuntu 14.04, so "systemctl" command does not exist. Also using Apache2 instead of nginx.
    Is there any alternative to starting pufferd? I looked up a few things and my only idea is to create a Upstart service for it, which I'm not sure I'm experienced enough to attempt. Any help would be greatly appreciated.

  • Your best bet is to then run pufferd in a screen or tmux.

    sudo -s
    su pufferd
    screen -S pufferd
    cd /srv/pufferd
    ./pufferd --config /etc/pufferd/config.json

  • Thank you! That worked to get the Daemon started, however, now it seems I'm stuck in the same boat as everyone here... "Cannot select plugin to create a server"
    Exact same errors as listed there. Well, I'll keep an eye on that thread, and will mark this as solved as you helped with the original issue. :)

Log in to reply





Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.