Cant create new server



  • So as said, i am unable to create a new server form the Pufferpanel. i get this error
    "An error occurred while trying to connect to the remote node. Please check that the daemon is running and try again.
    Daemon not available"
    Also i cant select any plugins..
    Daemon seems to be running.

    So tell me what log files are needed and how to get them, and ill be happy to post them here
    Ubuntu 16, Nix
    Also i have a red X under the node part of things



  • ~~If you're using Apache2, it sounds like the problem we're having here: https://community.pufferpanel.com/topic/466/cannot-select-plugin-to-create-a-server/13

    I temporarily got it working by using nginx instead, but I realize that's not a viable option for everyone.~~
    EDIT: never mind, it didn't work



  • im useing nginx as the website suggested, and Apache2 was purged before the install started



  • nothing? no one wants log files?



  • @woodzykiler said in Cant create new server:

    nothing? no one wants log files?

    This is a known issue, and the logs won't really help, because they are masking the error . https://community.pufferpanel.com/topic/466/cannot-select-plugin-to-create-a-server/15



  • Ill see what I can dig up maybe I can offer some insight on this. Im at work so it will be a while



  • Any update on the fix for this?
    Maybe u can add or enable some kind of a Debug mode?



  • @woodzykiler said in Cant create new server:

    Any update on the fix for this?
    Maybe u can add or enable some kind of a Debug mode?

    Next release removes the locking issue, which hides the true error. So once next release hits (trying to get them out as fast as I can), we'll be able to resolve this one quicker.



  • Please update to the latest release and replicate the error.

    You should then see logs in the /srv/pufferpanel/logs folder which contains the actual error.



  • So to update I have to uninstall everything or??



  • Just follow the instructions located under "Updating to 1.0.3" located here http://www.pufferpanel.com/docs/updating-pufferpanel#updating-to-103



  • Oh the NODES page the Status is green, when it was red on the last version. so im not sure what has changed. Also i can see the server types, and what not now. last version i could not. After this is fixed. how can i make a custom pre-built server, plugins and all like a base line

    first Log error is form the pannel (it seemed like it was going to work i can see everything)
    An error occurred while trying to connect to the remote node. Please check that the daemon is running and try again.
    Operation timed out after 5001 milliseconds with 0 bytes received

    Why its connecting to a remote node i dont understand. everything is on the same machine...

    This 2nd one is form the Log fiel requested
    [20:51:04] [INFO] pufferd v1.0.5 (2017-02-09_06:49:32PM 17ef2d96cd8a73910a1a6bb94d7227927f02fe48)
    [20:51:04] [INFO] Logging set to INFO
    [20:51:04] [INFO] No template directory found, creating
    [20:51:04] [INFO] Templates being copied to /var/lib/pufferd/templates
    [20:51:04] [INFO] No server directory found, creating
    [20:51:04] [WARN] No HTTPS.PEM found in data folder, will use no http
    [20:51:04] [DEBUG] Generating new key
    [20:51:04] [DEBUG] Loading existing key
    [20:51:04] [INFO] Started SFTP Server on 0.0.0.0:5657
    [20:51:04] [INFO] Starting web access on 0.0.0.0:5656
    [20:51:04] [DEBUG] Checking for updates using https://dl.pufferpanel.com/pufferd/v1.0/version.txt
    [20:54:19] [ERROR] Error talking to auth server
    Post http://73.29.147.200/oauth2/token/info: dial tcp 73.29.147.200:80: i/o timeout
    [20:54:19] [ERROR] Error handling route
    interface conversion: interface is nil, not string

    IO time out on its self-ip? i dont understand why it would need to ready that as the PufferPannel is on the same machine as the servers i with to have
    NOTE: i ran it a 2nd time ith the default ip of 0.0.0.0 and got the same thing



  • Is this server behind a NAT?

    I.E does using ip addr show that 73.29.147.200 or some 192.168/10.0.0 IP?



  • no NAT its connected on Network port 3
    Be mindfull its a home based HP Proliant DL380 G6 Two Quad Core E5540 2.53GHz 24GB RAM P410i 2X72GB Enterprise grade server (its in my house)

    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: enp3s0f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:26:55:51:3b:8c brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.82/24 brd 10.0.0.255 scope global enp3s0f0
    valid_lft forever preferred_lft forever
    inet6 2601:80:8501:3973:226:55ff:fe51:3b8c/64 scope global mngtmpaddr dynamic
    valid_lft 299796sec preferred_lft 299796sec
    inet6 fe80::226:55ff:fe51:3b8c/64 scope link
    valid_lft forever preferred_lft forever
    3: enp3s0f1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 00:26:55:51:3b:8e brd ff:ff:ff:ff:ff:ff
    4: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default
    link/ether 02:42:7b:bc:42:28 brd ff:ff:ff:ff:ff:ff
    inet 172.17.0.1/16 scope global docker0
    valid_lft forever preferred_lft forever



  • Then that would be the issue.

    pufferd tries to ask 73.29.147.200 for the information, but some routing hardware has issues talking to itself.

    The best way to resolve this would be having nginx also listen on the local IP (editing the server_name in the /etc/nginx/sites-enabled/pufferpanel.conf or /etc/nginx/conf.d/pufferpanel.conf) and then updating the /etc/pufferd/config.json file to point to the new URL.



  • so but doing the fist part i just add a line saying
    server_name 127.0.0.1;



  • server_name 73.29.147.200 127.0.0.1;



  • same error... [15:33:38] [ERROR] Error talking to auth server
    Post http://73.29.147.200/oauth2/token/info: dial tcp 73.29.147.200:80: i/o timeout
    [15:33:38] [ERROR] Error handling route
    interface conversion: interface is nil, not string
    ill reboot the entire box now



  • An error occurred while trying to connect to the remote node. Please check that the daemon is running and try again.
    An error occurred trying to add a server. ({"error":"Receieved response i(int=401)"} ) [HTTP 500]
    (From the Panel its self)
    [15:37:50] [INFO] pufferd v1.0.5 (2017-02-09_06:49:32PM 17ef2d96cd8a73910a1a6bb94d7227927f02fe48)
    [15:37:50] [INFO] Logging set to INFO
    [15:37:50] [WARN] No HTTPS.PEM found in data folder, will use no http
    [15:37:50] [DEBUG] Loading existing key
    [15:37:50] [INFO] Started SFTP Server on 0.0.0.0:5657
    [15:37:50] [INFO] Starting web access on 0.0.0.0:5656
    [15:37:50] [DEBUG] Checking for updates using https://dl.pufferpanel.com/pufferd/v1.0/version.txt
    [15:38:23] [ERROR] Unexpected response code from auth server
    401
    [15:38:23] [ERROR] Error handling route
    interface conversion: interface is nil, not string
    [15:38:49] [ERROR] Unexpected response code from auth server
    401
    [15:38:49] [ERROR] Error handling route
    interface conversion: interface is nil, not string

    (From the log file)
    Stupid question, if the server and panel are on the same machine and when u go to make a server its a "remote node" why is it remote? if the listings are Localhost, shouldnt it bypass the remote node part?



  • In order to avoid having effectively 2 different systems, we still use the HTTP calls back and order to handle the data correctly and to avoid intentional issues. While it is a common setup to have the "remote" node be on the same machine, we keep it distinct to avoid having crazy special cases (local vs remote is a special case).

    The actual code is the same, regardless of where it's hosted, and I don't want to change that, because then you have issues where remote now has different code just because of that. It makes more sense from a dev perspective to remove as much special cases as possible.

    In your case, the daemon is now properly talking to the panel, which is good. But now it's being rejected because it's auth token is not what the panel expects.

    Can you please open the database, and for that node in the nodes table, copy the secret frmo it and place it in pufferd's config?


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.