Cant log in. Default nginx page seen



  • I'm doing this for the first time. so do be nice lol
    I just got a new G5 enterprise grade server and its setup and online.
    I have followed the Install setup for Pufferpanel the best i can. but i still get the nginx default page. and i would like to access it as "Admin.foxnetwork.us" and no idea how to do this. i did buy the domain name allready with namecheap(also lost on that setup). what info do you need from me to hel pp you guys out? i do run Ubuntu 16.4 and apache2 is removed with purge



  • First, make sure you restarted nginx just in case it failed:

    systemctl restart nginx

    Second, when you installed the panel, did you use that URL as the site's address, or did you use something else?



  • i did the restarts as suggested. and i used my external IP. same issue



  • You need to use the same address that you put when the installer asked for the site url.



  • So I don't use my external IP(27.46.11.200)? I use the internal IP(127.0.0.1)? I did use the external ip. When I did the setup I used the external ip



  • If you used (physically typed in) 27.46.11.200, then you need to use that to get to the server.



  • I have. And same issue I reinstalled pufferpanel like 3 times..



  • Follow my comments on https://community.pufferpanel.com/topic/439/connecting-externally/2 then to add more acceptable URLs to nginx (and then restart nginx)



  • Ok. When I did the setup I used my external IP. And this server_name file where would it be so I can edit it



  • [19:59:14] [INFO] pufferd v1.0.5 (2017-02-09_06:49:32PM 17ef2d96cd8a73910a1a6bb94d7227927f02fe48)
    [19:59:14] [INFO] Logging set to INFO
    [19:59:14] [WARN] No HTTPS.PEM found in data folder, will use no http
    [19:59:14] [DEBUG] Loading existing key
    [19:59:14] [INFO] Started SFTP Server on 0.0.0.0:5657
    [19:59:14] [INFO] Starting web access on 10.0.0.82:5656
    [19:59:14] [DEBUG] Checking for updates using https://dl.pufferpanel.com/pufferd/v1.0/version.txt
    [19:59:14] [ERROR] Error starting web service
    listen tcp 10.0.0.82:5656: bind: cannot assign requested address



  • You should not be touching the pufferd config, that is not the config that you should be editing.

    NGinx configs are located in /etc/nginx/conf.d or /etc/nginx/sites-enabled



  • OK so i got it to display. using the networks internal IP....
    but how do i setup puffer.myhostname.com
    and i have this...
    When i tryed to make a new server (i didnt have a plugin list as well)
    An error occurred while trying to connect to the remote node. Please check that the daemon is running and try again.
    Daemon not available

    root@Server:~# service pufferd status
    ● pufferd.service - pufferd daemon service
    Loaded: loaded (/etc/systemd/system/pufferd.service; enabled; vendor preset: enabled)
    Active: active (running) since Sat 2017-03-04 17:41:26 EST; 3min 14s ago
    Main PID: 4971 (pufferd)
    Tasks: 12 (limit: 4915)
    Memory: 8.0M
    CPU: 87ms
    CGroup: /system.slice/pufferd.service
    └─4971 /srv/pufferd/pufferd --config /etc/pufferd/config.json

    Mar 04 17:41:26 Server systemd[1]: Started pufferd daemon service.
    Mar 04 17:41:26 Server pufferd[4971]: [17:41:26] [INFO] pufferd v1.0.5 (2017-02-09_06:49:32PM 17ef2d
    Mar 04 17:41:26 Server pufferd[4971]: [17:41:26] [INFO] Logging set to INFO
    Mar 04 17:41:26 Server pufferd[4971]: [17:41:26] [WARN] No HTTPS.PEM found in data folder, will use
    Mar 04 17:41:26 Server pufferd[4971]: [17:41:26] [INFO] Started SFTP Server on 0.0.0.0:5657
    Mar 04 17:41:26 Server pufferd[4971]: [17:41:26] [INFO] Starting web access on 10.0.0.82:5656
    lines 1-16/16 (END)


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.