[ERROR] Unable to access jarfile server.jar



  • Hello u guys,

    I just installed pufferpanel on my VPS (Ubuntu 16.04)
    I followed the tutorial and everything worked fine my panel worked etc.
    But now i wanted to create a server so i choose Minecraft spigot as minecraft version.
    But when i want to start the server is sais: Starting serverError: Unable to access jarfile server.jar

    Does someone maybe know how to fix this?

    Kind regards,
    Jarno



  • Sounds like the server did not install.

    Press the install button and it should re-install the server.



  • @LordRalex when i try that it still doesn't work.
    But it also gives me a error:
    Loading BuildTools version: git-BuildTools-8aa3a22-59 (#59)
    Git name not set, setting it to default value.
    Exception in thread "main" java.io.IOException: Cannot run program "git" (in directory "."): error=2, No such file or directory
    at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
    at org.spigotmc.builder.Builder.runProcess(Builder.java:552)
    at org.spigotmc.builder.Builder.main(Builder.java:162)
    Caused by: java.io.IOException: error=2, No such file or directory
    at java.lang.UNIXProcess.forkAndExec(Native Method)
    at java.lang.UNIXProcess.<init>(UNIXProcess.java:247)
    at java.lang.ProcessImpl.start(ProcessImpl.java:134)
    at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
    ... 2 more



  • You don't have git installed, which is odd considering the installer should have added it.

    apt-get install git



  • @LordRalex Thanks, that worked!

    But now my server still doesnt have like the good files in it.
    When i connect to the FTPS.
    The plugin folder isn't seen as a actual folder
    http://prntscr.com/edn6im



  • Filezilla does not render the files correctly, and so we recommend WinSCP for now.

    We've resolved this issue in the next release, and are working to get it tested and released as quickly as we can.


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.