Error 1060 trying to upgrade Pufferpanel??



  • Hi i'm trying to run the upgrade on my pp but I get this error.
    name:/srv/pufferpanel$ sudo ./pufferpanel update
    [sudo] password for boss:

    Will open a connection to localhost:3306 using pufferpanel
    Warning: Using a password on the command line interface can be insecure.
    ERROR 1060 (42S21) at line 1: Duplicate column name 'docker'



  • That error can be ignored. It is there in case a person did not update from 0.7 to 0.8, the installer should have warned that the message is not something that's bad and it should have continued on upgrading.



  • But nothing happens after that i'm on 0.8.5.3 ??



  • Did you download 0.8.6 or 1.0.0?

    If that is all you saw when you did the update, it sounds like you just installed 0.8.6 (which falsely identifies as 0.8.5.3).



  • cd /srv
    curl -L -o pufferpanel.tar.gz https://git.io/vDz1T
    tar -xf pufferpanel.tar.gz
    cd pufferpanel
    ./pufferpanel update

    I don't realy know what ver. Do I get latest or do I have to download manualy ?



  • That should have been 1.0.0 based on the link.

    What is the entire log when you do the update?

    The untar should actually have done most of the "upgrades", the command just updates the database.



  • Well all I see on the command line is the message in the original post. Is there a log for the update somewhere?

    Well i made the upgrade.. :) I forgot to tar the file with sudo.. :) lol noob. But nafter pufferd deploy. and migrate. It fails on my BungeCoord server Node.
    fen@myhost1:/srv/pufferd$ sudo ./pufferd --config=/etc/pufferd/config.json --migrate
    [02:40:38] [INFO] Attempting to migrate
    [02:40:38] [ERROR] Error read server config
    unexpected end of JSON input
    [02:40:38] [INFO] Attempting to migrate ab3ba238-3e2f-40a5-9768-7ac18e5aa12f
    [02:40:38] [INFO] Attempting to migrate npm-debug
    [02:40:38] [ERROR] Error read server config
    invalid character 'i' after top-level value
    [02:40:38] [INFO] Migration complete, please restart pufferd to have it recognize the changes
    fen@myhost1:/srv/pufferd$ systemctl restart pufferd

    And this under the deploy as well
    [02:36:02] [ERROR] Error loading config
    open /etc/pufferd/config.json: no such file or directory



  • Well after upgrading to pufferd. Nothing is smooth :) The Migrate set all permision in /var/lib/pufferd/servers/sid to root:root Witch worked bad.

    And my hub server is trying to start a different jar bukkit. instead of sigot. Where do I set waht file to start?



  • You need to set the files to pufferd:pufferd, not root.

    And we use the server.jar as the main jar.



  • @LordRalex Ok I got that figured out. it is up and running. phu. Well hopefully the Scales features will bee implemented soon :) Thx for the response LordR :) Keep up the good work guys :) Oh and an other thing. I can not controll other owners servers anymore. as Admin ??? Please fix. I can not start the servers of some people??


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.