Welcome to the PufferPanel community forums! If you need help please register an account and post in the Support category.

pufferd daemon 1.0.5 error



  • Hello, i need help

    i got this error and here is my pufferd log.

    [23:19:58] [INFO] pufferd v1.0.5 (2017-02-09_06:49:32PM 17ef2d96cd8a73910a1a6bb94d7227927f02fe48)
    [23:19:58] [INFO] Logging set to INFO
    [23:19:58] [DEBUG] Loading server as standard
    [23:19:58] [DEBUG] Loading server as standard
    [23:19:58] [INFO] Loaded server 9ab6aed3-ffef-447f-8618-c2a811e52da4
    [23:19:58] [INFO] Starting server 9ab6aed3-ffef-447f-8618-c2a811e52da4
    [23:19:58] [DEBUG] Starting server 9ab6aed3-ffef-447f-8618-c2a811e52da4
    [23:19:58] [WARN] No HTTPS.PEM found in data folder, will use no http
    [23:19:58] [DEBUG] Loading existing key
    [23:19:58] [INFO] Started SFTP Server on 0.0.0.0:5657
    [23:19:58] [INFO] Starting web access on 0.0.0.0:5656
    [23:19:58] [DEBUG] Checking for updates using https://dl.pufferpanel.com/pufferd/v1.0/version.txt
    [23:20:25] [DEBUG] Download file from https://hub.spigotmc.org/jenkins/job/BuildTools/lastSuccessfulBuild/artifact/target/BuildTools.jar to /var/lib/pufferd/servers/9ab6aed3-ffef-447f-8618-c2a811e52da4
    [23:21:50] [ERROR] Unexpected response code from auth server
    504
    [23:21:50] [ERROR] Error handling route
    interface conversion: interface is nil, not string
    [23:21:55] [ERROR] Unexpected response code from auth server
    504
    [23:21:55] [ERROR] Error handling route
    interface conversion: interface is nil, not string
    [23:22:00] [ERROR] Unexpected response code from auth server
    504
    ...
    

    and also this error 0_1486744486792_2017-02-10_232850.jpg

    thank you..



  • PHP is timing out when pufferd attempts to talk to it for authorization.

    Please check the PHP logs for any errors:
    /var/log/php-fpm or similar



  • So i'll explain how i can fix this issue, somehow..
    fyi, i'm using ubuntu 16.04 64bit,

    first i check php7.0-fpm.log in /var/log/ like LordRalex said
    then i found something like

    server reached pm.max_children setting (5), consider raising it
    

    so i searching and found how to edit it in /etc/php/7.0/fpm/pool.d/www.conf and i raise it to 12 or more..

    also i editing my nginx config file to increase performance, i change

    events {
            worker_connections 1024; //my default is 768
             multi_accept on; //uncomment this
            use epoll; // write this
    }
    
    

    and you can search on google for more configuration

    and for pufferd, i try to find my own problem so first check my pufferd status

    systemctl status pufferd
    

    i think the problem is my daemon using ipv6 instead of ipv4, check it with command

    netstat -ntlp
    

    i found

    tcp6       0      0 :::25565      :::*        LISTEN      15187/pufferd
    
    

    so i check my pufferd config in /etc/pufferd/config.json
    and replace my server ip address

      "webhost": "YOUR_IP",
      "webport": "5656",
      "sftp": "YOUR_IP:PORT", //default port is 5657
    
    

    finally restart your service

    service nginx restart
    
    service php7.0-fpm restart
    
    systemctl restart pufferd
    

    i hope it can help,

    but the status icon still error, always loading icon i can't figure it for now.

    Thanks for your attention


Log in to reply
 

1
Online

666
Users

708
Topics

3.2k
Posts

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.