cannot execute binary file: Exec format error



  • hi
    i am trying to install pufferd, as it did not install during the panel installation, and it is refusing to install now

    root@s1:/srv/pufferd# sudo bash -c 'source <(curl -sSLk http://panel.mc.robking.xyz/auth/remote/deploy/b88e0396-90b2-49bb-a618-a20dc433a6d6)'
    System detected as some variant of Ubuntu or Debian.
    Installing some dependiencies.
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Unable to locate package lib32gcc1
    E: Unable to locate package lib32tinfo5
    E: Unable to locate package lib32z1
    E: Unable to locate package lib32stdc++6
    E: Couldn't find any package by regex 'lib32stdc++6'
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    100 11.0M  100 11.0M    0     0   725k      0  0:00:15  0:00:15 --:--:-- 1173k
    /dev/fd/63: line 64: ./pufferd: cannot execute binary file: Exec format error
    An error occurred while installing, halting...
    

    i have tried manually downloading pufferd from
    https://dl.pufferpanel.com/pufferd/v1.0.4/pufferd
    but i have the same error message:

    root@s1:/srv/pufferd# curl -O https://dl.pufferpanel.com/pufferd/v1.0.4/pufferd
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    100 11.0M  100 11.0M    0     0   675k      0  0:00:16  0:00:16 --:--:--  815k
    root@s1:/srv/pufferd# ls
    pufferd
    root@s1:/srv/pufferd# chmod +x pufferd 
    root@s1:/srv/pufferd# ./pufferd 
    -bash: ./pufferd: cannot execute binary file: Exec format error
    root@s1:/srv/pufferd# 
    

    it appears to not be compatiable with my machine (ubuntu 16.04, 32bit, 2gb ram)

    i have also attempted to build it from source, but i dont know how to get that working

    any help would be apreciated



  • That would be correct, we do not support 32 bit OSes at this time.

    While we could make a 32 bit version, most user should be using 64 bit. Is there any reason why you are still using 32 bit? Just because you have 2G ram?



  • @LordRalex said in cannot execute binary file: Exec format error:

    That would be correct, we do not support 32 bit OSes at this time.

    ok thanks any way

    While we could make a 32 bit version, most user should be using 64 bit. Is there any reason why you are still using 32 bit? Just because you have 2G ram?

    yep, thats the only reason

    its a laptop i got from my school 6-7 years ago, and i have been using it as a webserver and other things for the last 4 years

    i have just discovered that the processor is 64 bit capable, so i might upgrade the ram and install 64bit ubuntu depending on the price of ram


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.