Changing query-port or disabling query



  • Hi,my bungeecord server has 25565 port,and query-port 25565 (by default),query is enabled,I want to change the query-port or to disable query,because somebody is flooding my server on the query-port.....



  • If you want to turn it off for all servers I would recommend changing it in the master template file located here

    sudo nano /srv/pufferpanel/app/templates/server.properties.tpl
    

    and then simply turning off query there.



  • And if I want to change it ?



  • #Minecraft Server Properties
    #Generated by PufferPanel
    generator-settings=
    op-permission-level=4
    allow-nether=true
    level-name=world
    enable-query=true
    allow-flight=false
    announce-player-achievements=true
    server-port=%1$d
    query.port=%1$d
    level-type=DEFAULT
    enable-rcon=false
    force-gamemode=false
    level-seed=
    server-ip=%2$s
    max-build-height=256
    spawn-npcs=true
    white-list=false```
    

    to

    #Minecraft Server Properties
    #Generated by PufferPanel
    generator-settings=
    op-permission-level=4
    allow-nether=true
    level-name=world
    enable-query=true
    allow-flight=false
    announce-player-achievements=true
    server-port=%1$d
    query.port=1234 # <-- Can be anything
    level-type=DEFAULT
    enable-rcon=false
    force-gamemode=false
    level-seed=
    server-ip=%2$s
    max-build-height=256
    spawn-npcs=true
    white-list=false
    


  • But I need this for bungeecord......How can I change the query-port for my bungeecord server ?



  • so....anybody ?



  • Please help,I can put my server on gametracker :(



  • bump
    .............................



  • https://github.com/PufferPanel/Scales/blob/master/lib/plugins/bungeecord/main.js#L94

    Edit your Scales files, change that value to false.

    Restart scales.



  • Thanks :)


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.