Welcome to the PufferPanel community forums! If you need help please register an account and post in the Support category.

SFTP Connection drops after entering password.

  • Hi using Ubuntu 14.04. and latest Pufferpanel Scales. I have debuged sshd and I see that the pp- users in passwd file is using /bin/false..

    I also set UsePAM to no in /etc/ssh/sshd_config
    should I change the /bin/false to /bin/bash ?
    But how do i get this to new servers I make . so SFTP will work

    Have I forgotten something in the config when setting this up..
    I found this as well same problem as I have..


    caxerx created this issue in PufferPanel/PufferPanel

    closed Can't connect to sftp #601

  • I changed to /bin/bash in /etc/passwd and that worked, but will it do this if making a new server.. Testing ......

  • Seems to be my bad. there was an error when installing this I did not change in sshd_config. So changing Subsystem sftp to internal-sftp instead of default path :) may have fixed it.. but not 100% sure her..
    Pleas if anyone have something to add :)

Log in to reply