Scales Auto-Deploy Command Outputting Weird Error



  • When I try to run the scales auto-deploy command I get this weird error:

    [root@play ~]# sudo bash -c 'source <(curl -sSLk http://168.235.89.123/panel/auth/remote/deploy/c870eb85-1555-4265-b660-c0f47fa557bb)'
    /dev/fd/63: line 1: syntax error near unexpected token `newline'
    /dev/fd/63: line 1: `<!DOCTYPE html>'
    
    

    I am running CentOS 7.3.1611



  • That implies that your site url is wrong.

    We do not use subfolders with our setup, so why are you using that? That is going to break something.

    sudo bash -c 'source <(curl -sSLk http://168.235.89.123/auth/remote/deploy/c870eb85-1555-4265-b660-c0f47fa557bb)'

    That's probably the corrected URL for your setup.



  • @LordRalex I thought I fixed that so it wasn't a subfolder. You mean the "/panel" part, right?



  • That's correct.

    You had set the site url in the panel itself to contain that. You have to fix that by going to the "URL Settings" page and updating the links there.



  • @LordRalex Everytime I try to update the URL settings I click "update settings" and the page reloads with the old settings.



  • EDIT: I should note my instructions are on Ubuntu 15.10, not CentOS 7, so try to do the same as below with CentOS's native commands

    Tapiture, there is a weird bug with url changing, try this:
    From SSH, Elevate your permissions (i.e. sudo su), use your favorite CLI editing tool (I use nano on Ubuntu 15.10) and edit /srv/pufferpanel/src/routes/admin/settings/routes.php with the following change on line 163:

    //'assets_url' => $request->param('assets_url')
    

    Save the change, restart nginx (just to be sure the change is noticed, service nginx restart) update your url in the pufferpanel settings, and put line 163 back to

    'assets_url' => $request->param('assets_url')
    

    Save, restart nginx again, and your site url will be updated.


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.