Cannot access PufferPanel website internally



  • Hi all,

    I'm pretty new to PufferPanel and Linux in general, but I was interested in hosting Rust servers for a stream community of mine. I had originally started with SpaceCP which was very streamlined and worked quite well. However, it only supported Minecraft and development is apparently "on hold" so I wanted to move to something more cutting edge.

    I'm a big fan of open source projects so I did some Googling and came across this panel, which honestly seems pretty clean and crisp. However, after going through the initial install (http://www.pufferpanel.com/docs#), I am not able to access the web panel over port 80 or 443 from inside my network. I did some research of others who might have experienced this issue, so here's some information that might help up front:

    • I am running a CentOS 7.1 VM in an OpenStack environment. It has an internal IP address of 192.168.0.105 and a floating IP of
    • A netstat -plunt shows that nginx is listening on port 80.
    • An nginx -t shows that the syntax is okay and and that the configuration file test is successful.
    • The "domain name" (in this case, my local IP address since I'm not using a domain name) in the conf.d file is properly displaying as the local IP address of the machine.
    • Performing a curl -k http://10.3.19.51 or https://10.3.19.51 (my private IP address for the VM) fails due to connection timing out.
    • There is nothing in netstat -plunt for port 443 (and I don't really care, since http doesn't even work).
    • If I use PuTTY to Telnet to 10.3.19.51:80, I get a connection timed out after about 25 seconds, leading me to believe the port is indeed not responding on port 80, despite what the VM says.
    • Yes, I can ping and SSH to 10.3.19.51 from my machine.
    • I have confirmed using systemctl status firewalld that the firewall service is stopped (cannot be found).

    To the best of my knowledge I had no issues installing. I confirmed all services that were supposed to be started/enabled are indeed running. I rebooted the server as well and confirmed the same again afterwards.

    Please let me know if there's anything else I can provide to help troubleshoot this. Most of what I'm finding online is related to Scales, but I haven't got that far yet.

    EDIT: Might I also add that I'm using PHP7. Could this be causing the issue, despite the successful install? I'm guessing not, since the prerequisites checked out with everything required [Installed], including PHP 5.5.0+.
    EDIT2: I also realized that SSL isn't working because it's all commented out in the conf.d file. I tried to uncomment out the second server portion and restart the services but now I'm getting a bunch of errors starting nginx. I might try rebuilding and starting over from scratch here shortly...
    EDIT3: I did start over from scratch and I'm having the same issue. Haven't touched any settings other than those in the installation instructions. I still can't get to the web interface. FWIW, here are some things I needed to make my own decisions on during the configuration that WEREN'T covered in the install instructions:

    What am I doing wrong here?

    UPDATES

    1. mariadb required additional configuration. I removed the anonymous user and disallowed root access remotely.
    2. MySQL also required additional configuration once I began the PufferPanel installation. I defaulted to localhost for the host name, 3306 for the port, root for the username, and my standard password for the password. For the site details, I entered the VMs IP address. When configuring site details, it asked for a username which I chose as root. The email I used was root@root.com (until I figure out what this is really for). And password was my standard.

    So in typical idiot fashion, I forgot about the OpenStack access groups. I created a new one to allow 80/443 and applied it to the VM. I am now able to get to http://10.3.19.51:80 via Chrome but I am getting a 404 error after installing PufferPanel. I can also successfully run curl -k 10.3.19.51 and I get a string of HTML stating some information about a test page for the Nginx HTTP server on Fedora (I'm using CentOS if you read below). Any ideas why I'm not being brought to the PufferPanel page?

    FWIW: I was brought to another article similar to my issue where someone was getting an error 404. He had accidentally installed to /root/srv/pufferpanel. I confirmed that my installation is indeed installed to /srv/pufferpanel (confirmed via dir). I also obtained some information from the /var/log/nginx/error.log and received the following output:

    2016/12/15 14:13:28 [crit] 12448#0: *6 stat() "/srv/pufferpanel/public/router.php" failed (13: Permission denied), client: 10.3.19.201, server: 10.3.19.51, request: "GET / HTTP/1.1", host: "10.3.19.51"
    2016/12/15 14:16:44 [crit] 12448#0: *10 stat() "/srv/pufferpanel/public/router.php" failed (13: Permission denied), client: 10.3.19.201, server: 10.3.19.51, request: "GET / HTTP/1.1", host: "10.3.19.51"
    

    ISSUE RESOLVED

    I needed to run the following command on the VM:

    setenforce 0
    

    Once I did this, I was able to hit the web interface no problem.


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.