Pufferpanel on apache2



  • Hi, I´m trying to run pufferpanel on apache2 with a virtualhost on a diffrent port than 80,
    I tried everything in I could do to let this work, I use debian 8 with the latest apache2.
    I have php5 installed and mysql.

    • sidboy55555


  • I created a virtualhost and wich is the pufferpanel on, but I get the message that the /index does not exist.
    This is what I get if I try to go to the main page: https://ibin.co/357cTh5EW2VR.png and this is what I get if I go to the router.php: https://ibin.co/357cLZmuepWP.png . And this is my apache2 virtualhost conf: http://pastebin.com/7NhWaWZf . Is there a module that I need to enable in apache2? or is this just a bug of using apache? I use apache2 because I use it as a default. And want continue to use it.



  • Did you make sure your virtual host file is correct?
    <VirtualHost 192.168.1.1:port>
     
    ServerAdmin email@email.email
    ServerName domain.domain.domain
    DocumentRoot /var/www/html/domain_or_whatever
     
    ErrorLog ${APACHE_LOG_DIR}/domain_or_whatever_error.log
    CustomLog ${APACHE_LOG_DIR}/domain_or_whatever_access.log combined
     
    </VirtualHost>

    basically make sure it's pointing to an existing directory



  • http://pastebin.com/dmar8my9 this is my apache virtualhost config file, I have the panel on a different directory than my default website, and the panel is on the 5353 port. But still not working..



  • this is my access log: http://pastebin.com/YhipbvmV
    the error log is emty..



  • Hi,

    First I'd like to ask why are you using Apache2 over NGINX? NGINX is much faster and in my opinion much easier to maintain and configure.

    Anyways, can you please verify that your Apache syntax is correct? Run "apache2ctl configtest". If your syntax is valid, can you please verify that Apache is listening on port 5353? You can do this by running 'netstat -tapn | grep 5353' and you should see Apache listening on that port.

    Also, is this Apache version 2.2 or 2.4? The configuration for 2.4 is a bit different than 2.2.

    Cal



  • apache2ctl configtest command:
    Syntax OK

    netstat -tapn | grep 5353 command:
    tcp6 0 0 :::5353 :::* LISTEN 32625/apache2

    apache2 -version command:
    Server version: Apache/2.4.10 (Debian)

    And I want to stay with apache because its more my thing, I want to learn more about Linux in general and when I use somethings thats hard to configuration I will use more time to let it work.



  • Hi,

    Is mod_rewrite enabled? 'sudo a2enmod rewrite'

    I've never setup PP on Apache, just trying to help. Have you added this Stanza to the main Apache 2 configuration?

    DocumentRoot /srv/pufferpanel/public
    <Directory "/srv/pufferpanel/public">
        AllowOverride All
        Order Allow,Deny
        Allow from all
        Require all granted
    </Directory>
    
    /etc/apache2/apache2.conf
    /etc/apache2/sites-enabled/pufferpanel.conf
    

    apache2.conf should contain the Stanza I placed above, otherwise it should be a stock configuration. Place your actual vhost in the sites-available directory and verify its enabled by symlinking it to sites-enabled. Assuming you've done both of those things are you sure that your document root is correct and contains the PP files?

    edit: If you changed the document root from the default, make sure you edit the main stanza in apache2.conf to reflect your changes.



  • it worked!, I had to add those stanza is the main config. that was the fix thank you :)


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.