404 page



  • Hello i want to add sourcebans to the same server. But whatever i have tried it seems like puffer panel gives the 404 page whenever i try to go to the directory on the server. I am using ngix.



  • You need to edit the config of the site-enabled in nginx This one is for ubuntu and will be in a diffrent directory to what im about to post

    In ubuntu/Linux go to
    /etc/nginx/sites-enabled/
    Edit the file default and add a location block like this as shown in the image below
    Do not add the text that i have crossed out in red only use other arguments like index if you know what you are doing
    After you have edited the default file restart nginx

    alt text



  • Thing is that pufferpanel seems to block all directories that isnt puffer panel and even as i did what you said i get this when i try to go to the directory! I have my files in /usr/share/nginx/html/sadmin
    0_1480257381122_asd.png



  • You need to put the directory in the pufferpanel directory which is in /srv/pufferpanel if you are on Linux or you could try create a symbolic link to the directory it works for me



  • @xXBuilderBXx
    Yeah i tried that still doesnt work.. tried to add it both to pufferpanel.conf and default and now it just downloads the files instead of execute.



  • Post your sites-available default file to pastebin and put the link here



  • @xXBuilderBXx http://pastebin.com/S65PfkhH sadmin is the directory where all sourcebans files are index and install etc.



  • Have you been restarting the nginx service? everytime you edit the default file other than that i dont see anything wrong with it unless you are doing something wrong on your end. Also have tried setting the permissions on the directory and files if you are running Linux.



  • @xXBuilderBXx Yeah i have done everything used different browsers restarted ngix updated the default file in several ways checked the permissions. when i example go to ip/sadmin/ i get prompted to log in to puffer panel and that is what makes me think that every directory except pufferpanel directorys arent allowed to be accesed. even tough i have added the map to the pufferpanel directory.



  • This is why you should be using subdomains. Altering the PufferPanel config is going to (unlikely, but not the real point) conflict with what we are trying to do.

    Create a subdomain that you use to access Pufferpanel, then create a subdomain for your sourcebans site.

    Create an nginx config for the sourcebans site that uses the server_name set to that subdomain.

    Update PufferPanel to the subdomain, then update the nginx config for that to use that subdomain as the server_name.



  • @LordRalex i only use ip atm for the website.


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.