Isue in the instalation



  • Installing user...
    Installing nginx config (if possible)

    • Restarting nginx nginx [fail]

    Would you like to thank us? Each thanks gives us the motivation to provide this software to you. [Y/n]: n

    Thank you for installing PufferPanel!
    Assuming that the installation completed, you will be able to visit your new panel at http://91.134.250.84
    root@omgserv-72903:/srv/pufferpanel#



  • I have this page: http://91.134.250.84/ What I can do ?



  • Sorry I am so noob in this.....but I have done the instalation for 0.8.5,and worked perfect (june) and now I want to install pufferpanel on other VPS.



  • Hello

    The ip you provided is working. You would need to manually visit (ip)/auth/login or simply remove apache2 if you would not be needing it..



  • @dino147 if you can try using mine

    server {
    	######
    	#	Listen port
    	######
            listen 80 default_server;		#IPv4
            listen [::]:80 default_server;		#IPv6
    
    		
    	######
            # SSL configuration
            ######
            # listen 443 ssl default_server;
            # listen [::]:443 ssl default_server;
            #
            # Note: You should disable gzip for SSL traffic.
            # See: https://bugs.debian.org/773332
            #
            # Read up on ssl_ciphers to ensure a secure configuration.
            # See: https://bugs.debian.org/765782
            #
            # Self signed certs generated by the ssl-cert package
            # Don't use them in a production server!
            #
            # include snippets/snakeoil.conf;
    
    		
    		
    	######
    	#	Root directory info
    	#		default directory where the files will be stored and served from
    	######
            root /srv/pufferpanel/; 
    		
    		
    		
    	######
    	#	The index file
    	#		index defined to be served under directory
    	######
            index index.php;
    
    		
    		
    	######
    	#	Server name
    	#		Name of the virtual host or domain
    	######
            server_name your.domain;
    		
    		
    		
    	######
    	#	Redirect to index
    	######
            #location / {
    	#	try_files $uri /router.php?$args =404;
    	#}
    		
    		
    		
    	######
    	#	PHP Settings
            #		Serve PHP scripts to FastCGI server our php-fpm server listening on php7.0-fpm.sock
    	######
    	#location ~ \.php$ {	
            location / { 
    	try_files /public/router.php =404;
            # With php7-fpm:
            fastcgi_pass unix:/run/php/php7.0-fpm.sock;
            include fastcgi_params;
            fastcgi_split_path_info ^(.+?\.php)(/.*)$;
            fastcgi_index router.php;
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
            include /etc/nginx/fastcgi_params;		
    	}
    		
    		
    	
    	######
    	#	Directory listing
    	######	
    	#location / {
            #       autoindex off;
            #}
    		
    		
    		
    	######
    	#	404 Page
    	######
    	error_page 404 /404.html;
    	
    
    	location /assets {
            try_files /app/$uri =404;
        	}	
    		
    		
    	######
            #	50x error
    	######
    	error_page 500 502 503 504 /50x.html;
    		
    		
    		
    	######
    	#	Ht access things
    	#		deny access to .htaccess files, if Apache's document root
    	######
            location ~ /\.ht {
    			deny all;
            }		
    
    	client_max_body_size 20m;
        	client_body_timeout 120s;
    
    }
    

    (Replace the server name)



  • @Pandry That would kind of work but Apache2 is covering the homepage which should auto redirect to /auth/login ... You would need to remove it from the sites-enabled.



  • @falceso You CAN'T use Apache2 AND Nginx togheder on the same port!
    I suggest you to use Nginx...



  • @Pandry Yeah totally... You can run it together but Nginx would mostly be a reverse proxy for Apache2.

    KBeezie Info on Apache with Nginx
    DigitalOcean Nginx as a Reverse Proxy for Apache



  • @falceso I were talking about 2 webserver, and anyway you can't have nginx and apache togheder listening on the same port...
    Or anyway apache should listen on 127.0.0.1 only and nginx on the public IP...



  • @falceso I've just saw the port on Digitalocean and, as you can see, they are on two different port...
    And anyway I think it's useless to use nginx for the frontend and apache for the backend...
    Whata waste of resources...
    Better use nginx only :D



  • @Pandry Didn't you read what I said? You can run it together but Nginx would mostly be a reverse proxy for Apache2.



  • @Pandry Also it's not a waste because some people like to use apache2 for their website. Apache2 is more common in most installations.



  • @falceso No...
    A reverse proxy in local is almost useless...
    You could use both of them for example 1 for the HTTP and one for the HTTPS, but for me, is useless...
    FOR ME is better to migrate to nginx, that is easyer and faster...



  • I uninstalled apahe2 and now works,solved.



  • @dino147 that would be because the conflict to each other, unless you configure it right, you can only have one or the other


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.