Problems with instalation Ubuntu 15.10 64 bits



  • I have this error aftfer doing the instaltion:
    Please enter the following information for the new admin user
    Username: ******
    Email: [Removed by moderator: Please do not post personal information]
    Password:
    Installing user...
    Warning: Using a password on the command line interface can be insecure.
    Installing nginx config (if possible)
    An existing configuration exists in /etc/nginx/sites-enabled

    Would you like to thank us? Each thanks gives us the motivation to provide this software to you. [Y/n]: n

    Thank you for installing PufferPanel!
    Assuming that the installation completed, you will be able to visit your new panel at http://91.134.250.84



  • "An existing configuration exists in /etc/nginx/sites-enabled"

    That's pretty clear what the error is. You already installed the panel at least once, and you did not remove that config for nginx from before.



  • When I put this command:
    sudo apt-get install -y openssl curl nginx git mysql-client mysql-server php5-fpm php5-cli php5-curl php5-mysql php5-mcrypt
    And after seting my msql password (I think,and confirmed)
    Selecting previously unselected package libxau6:amd64.
    (Reading database ... 26102 files and directories currently installed.)
    Preparing to unpack .../libxau6_1%3a1.0.8-1_amd64.deb ...
    Unpacking libxau6:amd64 (1:1.0.8-1) ...
    Selecting previously unselected package libxdmcp6:amd64.
    Preparing to unpack .../libxdmcp6_1%3a1.1.2-1_amd64.deb ...
    Unpacking libxdmcp6:amd64 (1:1.1.2-1) ...
    Selecting previously unselected package libaio1:amd64.
    Preparing to unpack .../libaio1_0.3.110-1_amd64.deb ...
    Unpacking libaio1:amd64 (0.3.110-1) ...
    Selecting previously unselected package libjpeg-turbo8:amd64.
    Preparing to unpack .../libjpeg-turbo8_1.3.0-0ubuntu2_amd64.deb ...
    Unpacking libjpeg-turbo8:amd64 (1.3.0-0ubuntu2) ...
    Selecting previously unselected package mysql-common.
    Preparing to unpack .../mysql-common_5.6.31-0ubuntu0.15.10.1_all.deb ...
    Unpacking mysql-common (5.6.31-0ubuntu0.15.10.1) ...
    Selecting previously unselected package libmysqlclient18:amd64.
    Preparing to unpack .../libmysqlclient18_5.6.31-0ubuntu0.15.10.1_amd64.deb ...
    Unpacking libmysqlclient18:amd64 (5.6.31-0ubuntu0.15.10.1) ...
    Selecting previously unselected package libxcb1:amd64.
    Preparing to unpack .../libxcb1_1.11-0ubuntu1_amd64.deb ...
    Unpacking libxcb1:amd64 (1.11-0ubuntu1) ...
    Selecting previously unselected package libx11-data.
    Preparing to unpack .../libx11-data_2%3a1.6.3-1ubuntu2_all.deb ...
    Unpacking libx11-data (2:1.6.3-1ubuntu2) ...
    Selecting previously unselected package libx11-6:amd64.
    Preparing to unpack .../libx11-6_2%3a1.6.3-1ubuntu2_amd64.deb ...
    Unpacking libx11-6:amd64 (2:1.6.3-1ubuntu2) ...
    Selecting previously unselected package libxpm4:amd64.
    Preparing to unpack .../libxpm4_1%3a3.5.11-1_amd64.deb ...
    Unpacking libxpm4:amd64 (1:3.5.11-1) ...
    Selecting previously unselected package libxslt1.1:amd64.
    Preparing to unpack .../libxslt1.1_1.1.28-2build2_amd64.deb ...
    Unpacking libxslt1.1:amd64 (1.1.28-2build2) ...
    Selecting previously unselected package libdbi-perl.
    Preparing to unpack .../libdbi-perl_1.633-1_amd64.deb ...
    Unpacking libdbi-perl (1.633-1) ...
    Selecting previously unselected package libdbd-mysql-perl.
    Preparing to unpack .../libdbd-mysql-perl_4.028-2_amd64.deb ...
    Unpacking libdbd-mysql-perl (4.028-2) ...
    Selecting previously unselected package libterm-readkey-perl.
    Preparing to unpack .../libterm-readkey-perl_2.33-1_amd64.deb ...
    Unpacking libterm-readkey-perl (2.33-1) ...
    Selecting previously unselected package mysql-client-core-5.6.
    Preparing to unpack .../mysql-client-core-5.6_5.6.31-0ubuntu0.15.10.1_amd64.deb ...
    Unpacking mysql-client-core-5.6 (5.6.31-0ubuntu0.15.10.1) ...
    Selecting previously unselected package mysql-client-5.6.
    Preparing to unpack .../mysql-client-5.6_5.6.31-0ubuntu0.15.10.1_amd64.deb ...
    Unpacking mysql-client-5.6 (5.6.31-0ubuntu0.15.10.1) ...
    Selecting previously unselected package mysql-server-core-5.6.
    Preparing to unpack .../mysql-server-core-5.6_5.6.31-0ubuntu0.15.10.1_amd64.deb ...
    Unpacking mysql-server-core-5.6 (5.6.31-0ubuntu0.15.10.1) ...
    Processing triggers for man-db (2.7.4-1) ...
    Setting up mysql-common (5.6.31-0ubuntu0.15.10.1) ...
    update-alternatives: using /etc/mysql/my.cnf.fallback to provide /etc/mysql/my.cnf (my.cnf) in auto mode
    Selecting previously unselected package mysql-server-5.6.
    (Reading database ... 26781 files and directories currently installed.)
    Preparing to unpack .../mysql-server-5.6_5.6.31-0ubuntu0.15.10.1_amd64.deb ...
    Unpacking mysql-server-5.6 (5.6.31-0ubuntu0.15.10.1) ...
    Selecting previously unselected package libjbig0:amd64.
    Preparing to unpack .../libjbig0_2.1-3.1_amd64.deb ...
    Unpacking libjbig0:amd64 (2.1-3.1) ...
    Selecting previously unselected package libhtml-tagset-perl.
    Preparing to unpack .../libhtml-tagset-perl_3.20-2_all.deb ...
    Unpacking libhtml-tagset-perl (3.20-2) ...
    Selecting previously unselected package liburi-perl.
    Preparing to unpack .../liburi-perl_1.69-1_all.deb ...
    Unpacking liburi-perl (1.69-1) ...
    Selecting previously unselected package libhtml-parser-perl.
    Preparing to unpack .../libhtml-parser-perl_3.71-2_amd64.deb ...
    Unpacking libhtml-parser-perl (3.71-2) ...
    Selecting previously unselected package libcgi-pm-perl.
    Preparing to unpack .../libcgi-pm-perl_4.21-1_all.deb ...
    Unpacking libcgi-pm-perl (4.21-1) ...
    Selecting previously unselected package libfcgi-perl.
    Preparing to unpack .../libfcgi-perl_0.77-1_amd64.deb ...
    Unpacking libfcgi-perl (0.77-1) ...
    Selecting previously unselected package libcgi-fast-perl.
    Preparing to unpack .../libcgi-fast-perl_1%3a2.10-1_all.deb ...
    Unpacking libcgi-fast-perl (1:2.10-1) ...
    Selecting previously unselected package libencode-locale-perl.
    Preparing to unpack .../libencode-locale-perl_1.03-1_all.deb ...
    Unpacking libencode-locale-perl (1.03-1) ...
    Selecting previously unselected package libtimedate-perl.
    Preparing to unpack .../libtimedate-perl_2.3000-2_all.deb ...
    Unpacking libtimedate-perl (2.3000-2) ...
    Selecting previously unselected package libhttp-date-perl.
    Preparing to unpack .../libhttp-date-perl_6.02-1_all.deb ...
    Unpacking libhttp-date-perl (6.02-1) ...
    Selecting previously unselected package libio-html-perl.
    Preparing to unpack .../libio-html-perl_1.001-1_all.deb ...
    Unpacking libio-html-perl (1.001-1) ...
    Selecting previously unselected package liblwp-mediatypes-perl.
    Preparing to unpack .../liblwp-mediatypes-perl_6.02-1_all.deb ...
    Unpacking liblwp-mediatypes-perl (6.02-1) ...
    Selecting previously unselected package libhttp-message-perl.
    Preparing to unpack .../libhttp-message-perl_6.06-1_all.deb ...
    Unpacking libhttp-message-perl (6.06-1) ...
    Selecting previously unselected package librtmp1:amd64.
    Preparing to unpack .../librtmp1_2.4+20150115.gita107cef-1build1_amd64.deb ...
    Unpacking librtmp1:amd64 (2.4+20150115.gita107cef-1build1) ...
    Selecting previously unselected package libcurl3-gnutls:amd64.
    Preparing to unpack .../libcurl3-gnutls_7.43.0-1ubuntu2.1_amd64.deb ...
    Unpacking libcurl3-gnutls:amd64 (7.43.0-1ubuntu2.1) ...
    Preparing to unpack .../openssl_1.0.2d-0ubuntu1.5_amd64.deb ...
    Unpacking openssl (1.0.2d-0ubuntu1.5) over (1.0.2d-0ubuntu1.3) ...
    Selecting previously unselected package curl.
    Preparing to unpack .../curl_7.43.0-1ubuntu2.1_amd64.deb ...
    Unpacking curl (7.43.0-1ubuntu2.1) ...
    Selecting previously unselected package liberror-perl.
    Preparing to unpack .../liberror-perl_0.17-1.1_all.deb ...
    Unpacking liberror-perl (0.17-1.1) ...
    Selecting previously unselected package git-man.
    Preparing to unpack .../git-man_1%3a2.5.0-1ubuntu0.2_all.deb ...
    Unpacking git-man (1:2.5.0-1ubuntu0.2) ...
    Selecting previously unselected package git.
    Preparing to unpack .../git_1%3a2.5.0-1ubuntu0.2_amd64.deb ...
    Unpacking git (1:2.5.0-1ubuntu0.2) ...
    Selecting previously unselected package libcurl3:amd64.
    Preparing to unpack .../libcurl3_7.43.0-1ubuntu2.1_amd64.deb ...
    Unpacking libcurl3:amd64 (7.43.0-1ubuntu2.1) ...
    Selecting previously unselected package libjpeg8:amd64.
    Preparing to unpack .../libjpeg8_8c-2ubuntu8_amd64.deb ...
    Unpacking libjpeg8:amd64 (8c-2ubuntu8) ...
    Selecting previously unselected package libtiff5:amd64.
    Preparing to unpack .../libtiff5_4.0.3-12.3ubuntu2.1_amd64.deb ...
    Unpacking libtiff5:amd64 (4.0.3-12.3ubuntu2.1) ...
    Selecting previously unselected package libvpx2:amd64.
    Preparing to unpack .../libvpx2_1.4.0-4_amd64.deb ...
    Unpacking libvpx2:amd64 (1.4.0-4) ...
    Selecting previously unselected package libgd3:amd64.
    Preparing to unpack .../libgd3_2.1.1-4ubuntu0.15.10.2_amd64.deb ...
    Unpacking libgd3:amd64 (2.1.1-4ubuntu0.15.10.2) ...
    Selecting previously unselected package libhtml-template-perl.
    Preparing to unpack .../libhtml-template-perl_2.95-2_all.deb ...
    Unpacking libhtml-template-perl (2.95-2) ...
    Selecting previously unselected package libmcrypt4.
    Preparing to unpack .../libmcrypt4_2.5.8-3.3_amd64.deb ...
    Unpacking libmcrypt4 (2.5.8-3.3) ...
    Selecting previously unselected package mysql-client.
    Preparing to unpack .../mysql-client_5.6.31-0ubuntu0.15.10.1_all.deb ...
    Unpacking mysql-client (5.6.31-0ubuntu0.15.10.1) ...
    Selecting previously unselected package mysql-server.
    Preparing to unpack .../mysql-server_5.6.31-0ubuntu0.15.10.1_all.deb ...
    Unpacking mysql-server (5.6.31-0ubuntu0.15.10.1) ...
    Selecting previously unselected package nginx-common.
    Preparing to unpack .../nginx-common_1.9.3-1ubuntu1.2_all.deb ...
    Unpacking nginx-common (1.9.3-1ubuntu1.2) ...
    Selecting previously unselected package nginx-core.
    Preparing to unpack .../nginx-core_1.9.3-1ubuntu1.2_amd64.deb ...
    Unpacking nginx-core (1.9.3-1ubuntu1.2) ...
    Selecting previously unselected package nginx.
    Preparing to unpack .../nginx_1.9.3-1ubuntu1.2_all.deb ...
    Unpacking nginx (1.9.3-1ubuntu1.2) ...
    Selecting previously unselected package php5-common.
    Preparing to unpack .../php5-common_5.6.11+dfsg-1ubuntu3.4_amd64.deb ...
    Unpacking php5-common (5.6.11+dfsg-1ubuntu3.4) ...
    Selecting previously unselected package php5-json.
    Preparing to unpack .../php5-json_1.3.7-1_amd64.deb ...
    Unpacking php5-json (1.3.7-1) ...
    Selecting previously unselected package php5-cli.
    Preparing to unpack .../php5-cli_5.6.11+dfsg-1ubuntu3.4_amd64.deb ...
    Unpacking php5-cli (5.6.11+dfsg-1ubuntu3.4) ...
    Selecting previously unselected package php5-curl.
    Preparing to unpack .../php5-curl_5.6.11+dfsg-1ubuntu3.4_amd64.deb ...
    Unpacking php5-curl (5.6.11+dfsg-1ubuntu3.4) ...
    Selecting previously unselected package php5-fpm.
    Preparing to unpack .../php5-fpm_5.6.11+dfsg-1ubuntu3.4_amd64.deb ...
    Unpacking php5-fpm (5.6.11+dfsg-1ubuntu3.4) ...
    Selecting previously unselected package php5-mcrypt.
    Preparing to unpack .../php5-mcrypt_5.4.6-0ubuntu6_amd64.deb ...
    Unpacking php5-mcrypt (5.4.6-0ubuntu6) ...
    Selecting previously unselected package php5-mysql.
    Preparing to unpack .../php5-mysql_5.6.11+dfsg-1ubuntu3.4_amd64.deb ...
    Unpacking php5-mysql (5.6.11+dfsg-1ubuntu3.4) ...
    Selecting previously unselected package php5-readline.
    Preparing to unpack .../php5-readline_5.6.11+dfsg-1ubuntu3.4_amd64.deb ...
    Unpacking php5-readline (5.6.11+dfsg-1ubuntu3.4) ...
    Processing triggers for systemd (225-1ubuntu9) ...
    Processing triggers for man-db (2.7.4-1) ...
    Setting up libxau6:amd64 (1:1.0.8-1) ...
    Setting up libxdmcp6:amd64 (1:1.1.2-1) ...
    Setting up libaio1:amd64 (0.3.110-1) ...
    Setting up libjpeg-turbo8:amd64 (1.3.0-0ubuntu2) ...
    Setting up libmysqlclient18:amd64 (5.6.31-0ubuntu0.15.10.1) ...
    Setting up libxcb1:amd64 (1.11-0ubuntu1) ...
    Setting up libx11-data (2:1.6.3-1ubuntu2) ...
    Setting up libx11-6:amd64 (2:1.6.3-1ubuntu2) ...
    Setting up libxpm4:amd64 (1:3.5.11-1) ...
    Setting up libxslt1.1:amd64 (1.1.28-2build2) ...
    Setting up libdbi-perl (1.633-1) ...
    Setting up libdbd-mysql-perl (4.028-2) ...
    Setting up libterm-readkey-perl (2.33-1) ...
    Setting up mysql-client-core-5.6 (5.6.31-0ubuntu0.15.10.1) ...
    Setting up mysql-client-5.6 (5.6.31-0ubuntu0.15.10.1) ...
    Setting up mysql-server-core-5.6 (5.6.31-0ubuntu0.15.10.1) ...
    Setting up mysql-server-5.6 (5.6.31-0ubuntu0.15.10.1) ...
    update-alternatives: using /etc/mysql/mysql.cnf to provide /etc/mysql/my.cnf (my.cnf) in auto mode
    2016-08-31 13:52:32 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
    2016-08-31 13:52:32 0 [Note] /usr/sbin/mysqld (mysqld 5.6.31-0ubuntu0.15.10.1) starting as process 4819 ...
    Setting up libjbig0:amd64 (2.1-3.1) ...
    Setting up libhtml-tagset-perl (3.20-2) ...
    Setting up liburi-perl (1.69-1) ...
    Setting up libhtml-parser-perl (3.71-2) ...
    Setting up libcgi-pm-perl (4.21-1) ...
    Setting up libfcgi-perl (0.77-1) ...
    Setting up libcgi-fast-perl (1:2.10-1) ...
    Setting up libencode-locale-perl (1.03-1) ...
    Setting up libtimedate-perl (2.3000-2) ...
    Setting up libhttp-date-perl (6.02-1) ...
    Setting up libio-html-perl (1.001-1) ...
    Setting up liblwp-mediatypes-perl (6.02-1) ...
    Setting up libhttp-message-perl (6.06-1) ...
    Setting up librtmp1:amd64 (2.4+20150115.gita107cef-1build1) ...
    Setting up libcurl3-gnutls:amd64 (7.43.0-1ubuntu2.1) ...
    Setting up openssl (1.0.2d-0ubuntu1.5) ...
    Setting up curl (7.43.0-1ubuntu2.1) ...
    Setting up liberror-perl (0.17-1.1) ...
    Setting up git-man (1:2.5.0-1ubuntu0.2) ...
    Setting up git (1:2.5.0-1ubuntu0.2) ...
    Setting up libcurl3:amd64 (7.43.0-1ubuntu2.1) ...
    Setting up libjpeg8:amd64 (8c-2ubuntu8) ...
    Setting up libtiff5:amd64 (4.0.3-12.3ubuntu2.1) ...
    Setting up libvpx2:amd64 (1.4.0-4) ...
    Setting up libgd3:amd64 (2.1.1-4ubuntu0.15.10.2) ...
    Setting up libhtml-template-perl (2.95-2) ...
    Setting up libmcrypt4 (2.5.8-3.3) ...
    Setting up mysql-client (5.6.31-0ubuntu0.15.10.1) ...
    Setting up mysql-server (5.6.31-0ubuntu0.15.10.1) ...
    Setting up nginx-common (1.9.3-1ubuntu1.2) ...
    Setting up nginx-core (1.9.3-1ubuntu1.2) ...
    Job for nginx.service failed because the control process exited with error code. See "systemctl status nginx.service" and "journalctl -xe" for details.
    invoke-rc.d: initscript nginx, action "start" failed.
    dpkg: error processing package nginx-core (--configure):
    subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of nginx:
    nginx depends on nginx-core (>= 1.9.3-1ubuntu1.2) | nginx-full (>= 1.9.3-1ubuntu1.2) | nginx-light (>= 1.9.3-1ubuntu1.2) | nginx-extras (>= 1.9.3-1ubuntu1.2); however:
    Package nginx-core is not configured yet.
    Package nginx-full is not installed.
    Package nginx-light is not installed.
    Package nginx-extras is not installed.
    nginx depends on nginx-core (<< 1.9.3-1ubuntu1.2.1~) | nginx-full (<< 1.9.3-1ubuntu1.2.1~) | nginx-light (<< 1.9.3-1ubuntu1.2.1~) | nginx-extras (<< 1.9.3-1ubuntu1.2.1~); however:
    Package nginx-core is not configured yet.
    Package nginx-full is not installed.
    Package nginx-light is not installed.
    Package nginx-extras is not installed.

    dpkg: error processing package nginx (--configure):
    dependency problems - leaving unconfigured
    Setting up php5-common (5.6.11+dfsg-1ubuntu3.4) ...

    Creating config file /etc/php5/mods-available/pdo.ini with new version
    php5_invoke: Enable module pdo for cli SAPI
    php5_invoke: Enable module pdo for fpm SAPI

    Creating config file /etc/php5/mods-available/opcache.ini with new version
    php5_invoke: Enable module opcache for cli SAPI
    php5_invoke: Enable module opcache for fpm SAPI
    Setting up php5-json (1.3.7-1) ...
    php5_invoke: Enable module json for cli SAPI
    php5_invoke: Enable module json for fpm SAPI
    Setting up php5-cli (5.6.11+dfsg-1ubuntu3.4) ...
    update-alternatives: using /usr/bin/php5 to provide /usr/bin/php (php) in auto mode

    Creating config file /etc/php5/cli/php.ini with new version
    Setting up php5-curl (5.6.11+dfsg-1ubuntu3.4) ...

    Creating config file /etc/php5/mods-available/curl.ini with new version
    php5_invoke: Enable module curl for cli SAPI
    php5_invoke: Enable module curl for fpm SAPI
    Setting up php5-fpm (5.6.11+dfsg-1ubuntu3.4) ...

    Creating config file /etc/php5/fpm/php.ini with new version
    Setting up php5-mcrypt (5.4.6-0ubuntu6) ...
    Setting up php5-mysql (5.6.11+dfsg-1ubuntu3.4) ...

    Creating config file /etc/php5/mods-available/mysql.ini with new version
    php5_invoke: Enable module mysql for cli SAPI
    php5_invoke: Enable module mysql for fpm SAPI

    Creating config file /etc/php5/mods-available/mysqli.ini with new version
    php5_invoke: Enable module mysqli for cli SAPI
    php5_invoke: Enable module mysqli for fpm SAPI

    Creating config file /etc/php5/mods-available/pdo_mysql.ini with new version
    php5_invoke: Enable module pdo_mysql for cli SAPI
    php5_invoke: Enable module pdo_mysql for fpm SAPI
    Setting up php5-readline (5.6.11+dfsg-1ubuntu3.4) ...

    Creating config file /etc/php5/mods-available/readline.ini with new version
    php5_invoke: Enable module readline for cli SAPI
    php5_invoke: Enable module readline for fpm SAPI
    Processing triggers for libc-bin (2.21-0ubuntu4.1) ...
    Processing triggers for systemd (225-1ubuntu9) ...
    Processing triggers for php5-fpm (5.6.11+dfsg-1ubuntu3.4) ...
    Errors were encountered while processing:
    nginx-core
    nginx
    E: Sub-process /usr/bin/dpkg returned an error code (1)



  • I have an error......and this afects all the instalation....



  • Try doing apt remove -y --purge nginx nginx-core


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.