Running a different java?



  • Hi there, im quickly asking if there is any way of running java 8 and java 7 on puffer panel at the same time, this can be archived normally by replacing "java" at the start of the start script with the directory of the java installation but i cant change the "java" variable on puffer panel, any way of doing this? that i might be missing.

    Thanks!



  • first i dont understand why you need to lower your java version because any java updates usually adds to the program and does not take away.

    that being said, i would think you can also define the java directory as one of the parameters.

    i know this is not a solution but i suggest trying to run whatever that needed java 7 on java 8 and see how it goes.



  • I currently run a modded network and i run different versions of minecraft from 1.5.2 to 1.8.9 and i can't run 1.5.2 minecraft on 1.8 java, but ill give it a try, I'm guessing by putting java | /path/to/java/place/java ?



  • well the whole predefined java thing can be removed from the script files if you so choose. although im not going to look for it but it would most likely be in a php file and look something similar to this:

    return java + $script;
    

    the script files are located in the lib (/srv/scales/lib) folder in scales and src (/srv/pufferpanel/src) for pufferpanel. your best bet is to find them in the scales directory.

    last, if you are uncomfortable editing code its better if you dont mess up your servers and lose data than to risk it.



  • i took a quick look for where that could be defined. you may want to try also the plugin config:
    /srv/scales/lib/plugins/minecraft/config.json

        "exe": "java",
        "pgrep_exe": "java",
    

    set this to

        "exe": "",
        "pgrep_exe": "",
    


  • Ok so ive tried that and ive replaced the config files with what you told me but its still running the default version of java on that node....

    " java ${java} -Xms4000M -Xmx4000M -server -jar server.jar -nogui " is what it says on kill



  • the examples i have given were not intend to be copied straight away because it can vary. if you feel not to comfortable editing php and/or JavaScript i suggest just getting a second deamon to run scales on java 7.



  • Would i have to restart the deamon if i were to edit the /srv/scales/lib ? if so how would i go about doing that



  • yea you need to restart scales

    go to /srv/scales
    ./scales stop
    ./scales start
    (scales doesn't have a restart feature)



  • Ok awesome everything seems to be working as it should be now apart from scales is detecting a crash when there is no crash, anyway to disable this? (Sorry for all the questions)

    "-su: line 1: 9792 Killed /usr/lib/jvm/java-7-oracle/jre/bin/java -Xms16000M -Xmx16000M -jar server.jar -nogui
    [Scales] [WARNING] This server has been detected as crashed by the management daemon. The restart process is being skipped due to the frequency at which this server is crashing (< 60 seconds between crashes)."

    Ive tried running it without the -nogui and changing all the variables around but it happens once the server is fully booted and then it changes the status to "on" then 3 seconds later scales sees it as a crash and killed the process..

    This applies for every server on that node. (Only thing that has been changed is the scripts inside the plugin. From "java" to ""



  • yea im not to sure mess around with changing there should be a sweet spot


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.