HELP!!! 404 after install.



  • I have tried everything that was said in the other posts.
    heres my output:
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 127.0.0.1:9000 0.0.0.0:* LISTEN 1642/php-fpm: maste
    tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 31613/mysqld
    tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 2428/nginx: master
    tcp 0 0 0.0.0.0:10000 0.0.0.0:* LISTEN 3796/perl
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1198/sshd
    tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 2342/master
    tcp 0 0 0.0.0.0:8443 0.0.0.0:* LISTEN 27682/mineos
    tcp6 0 0 :::80 :::* LISTEN 2428/nginx: master
    tcp6 0 0 :::22 :::* LISTEN 1198/sshd
    tcp6 0 0 ::1:25 :::* LISTEN 2342/master
    udp 0 0 0.0.0.0:39576 0.0.0.0:* 27682/mineos
    udp 0 0 0.0.0.0:40347 0.0.0.0:* 27682/mineos
    udp 0 0 0.0.0.0:10000 0.0.0.0:* 3796/perl
    udp 0 0 0.0.0.0:45690 0.0.0.0:* 27682/mineos

    obvious php-fpm is running and nginx is running.

    ive tried reinstalling pufferpanel and nginx ive tried EVERYTHING!

    why is it giving me a 404 error.

    all config files look as they should be their output match whats in the documentation.

    HELP ME PLZ!!!



  • Please provide the following information:

    • The location on your system of your PufferPanel install (usually /srv/pufferpanel)
    • The output of ls -al /srv/pufferpanel (replacing /srv/pufferpanel with wherever your install is located)
    • The distribution of Linux your server is running
    • The contents of /var/log/nginx/error.log and /var/log/nginx/access.log (you can paste these to http://paste.ee and give us the URL it takes you to)

    Thanks.



  • @puffrfish said:

    ls -al /srv/pufferpanel

    location /srv/pufferpanel

    [root@localhost pufferpanel]# ls -al /srv/pufferpanel
    total 1692
    drwxr-xr-x. 9 nginx nginx 4096 May 27 04:38 .
    drwxr-xr-x. 3 root root 4096 May 27 04:37 ..
    drwxr-xr-x. 6 nginx nginx 4096 Feb 19 14:06 app
    -rw-r--r--. 1 nginx nginx 489 Mar 10 16:36 composer.json
    -rw-r--r--. 1 nginx nginx 37617 Feb 19 14:06 composer.lock
    -rwxr-xr-x. 1 nginx nginx 1580316 Mar 10 16:36 composer.phar
    -rw-r--r--. 1 nginx nginx 256 May 27 05:50 config.json
    -rw-r--r--. 1 nginx nginx 6064 Mar 10 16:36 CONTRIBUTING.md
    drwxr-xr-x. 2 nginx nginx 4096 Mar 10 16:36 install
    -rw-r--r--. 1 nginx nginx 275 Mar 10 16:36 ISSUE_TEMPLATE.md
    -rw-r--r--. 1 nginx nginx 32452 Mar 10 16:36 LICENSE
    drwxrwxrwx. 2 nginx nginx 4096 Mar 10 16:36 logs
    drwxr-xr-x. 2 nginx nginx 4096 Mar 10 16:36 public
    -rwxr-xr-x. 1 nginx nginx 11547 Mar 10 16:36 pufferpanel
    -rw-r--r--. 1 nginx nginx 4442 Mar 10 16:36 README.md
    drwxr-xr-x. 6 nginx nginx 4096 Feb 19 14:06 src
    drwxr-xr-x. 2 nginx nginx 4096 Mar 10 16:36 tools
    drwxr-xr-x. 18 nginx nginx 4096 Mar 10 16:36 vendor

    Centos 7.1 x64 Server edition

    logs:
    http://paste.ee/p/Zn7Wx



  • Can you please provide /etc/nginx/conf.d/pufferpanel.conf and any other nginx config files found in there as well?



  • @puffrfish said:

    etc/nginx/conf.d/pufferpanel.conf

    only one conf file in conf.d and thats pufferpanel.conf

    heres the output:
    http://paste.ee/p/zhhAJ

    ive included /etc/nginx/nginx.conf output in there.



  • Could you please run the following command and provide the output from it?

    grep '^listen *=' /etc/php-fpm.d/www.conf
    


  • [root@localhost /]# grep '^listen *=' /etc/php-fpm.d/www.conf
    listen = 127.0.0.1:9000



  • On the fastcgi_pass line (line 15 of your paste) of the pufferpanel.conf replace unix:/var/run/php5-fpm.sock; with 127.0.0.1:9000;

    So it should now read

    fastcgi_pass 127.0.0.1:9000;
    

    Then restart nginx and see if that fixes it.



  • @puffrfish said:

    fastcgi_pass 127.0.0.1:9000;

    nope still 404.



  • I think the main issue is this:
    2016/05/27 08:41:41 [crit] 18612#0: *2 stat() "/srv/pufferpanel/public/router.php" failed (13: Permission denied), client: 69.133.202.230, server: 198.101.14.54, request: "GET / HTTP/1.1", host: "198.101.14.54"

    but how do i fix it. ive try setting tis permissions to 777 to see if that would fix it but it didnt work.
    ive even tried running chown -R nginx:nginx /srv/pufferpanel



  • Setting permissions to 777 is likely to break everything. Please re-download PufferPanel so everything is back to the default.

    To confirm, you restarted nginx as well?

    Edit: to clarify, you can just run these steps and everything will be back to the way it was http://www.pufferpanel.com/docs/updating-pufferpanel



  • If those steps do not work, please do the following:
    (as root)

    sed -i 's/SELINUX=enforcing/SELINUX=permissive/g' /etc/selinux/config
    setenforce permissive
    


  • ok its working now after i ran this:

    yum install -y policycoreutils-devel
    grep nginx /var/log/audit/audit.log | audit2allow -M nginx
    semodule -i nginx.pp
    setenforce 0
    

    ive only 777 that one file i can change it back.



  • Yes that is fine too, I thought you meant you chmod 777'd everything. Glad you got it working.


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.