Java X11 errors in 16.04



  • I know that 16.04 support is not ready, but I've been able to get as far as installing pufferpanel and scales and starting a server. When it starts, I get the following errors about X11:

    Server is starting...
    
    ---------Running Pre-Flight, this might take a moment or two...---------
    
    No protocol specified
    Exception in thread "main" java.awt.AWTError: Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable.	at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)	at sun.awt.X11GraphicsEnvironment.access$200(X11GraphicsEnvironment.java:65)	at sun.awt.X11GraphicsEnvironment$1.run(X11GraphicsEnvironment.java:115)	at java.security.AccessController.doPrivileged(Native Method)	at sun.awt.X11GraphicsEnvironment.<clinit>(X11GraphicsEnvironment.java:74)	at java.lang.Class.forName0(Native Method)	at java.lang.Class.forName(Class.java:264)	at java.awt.GraphicsEnvironment.createGE(GraphicsEnvironment.java:103)	at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:82)	at sun.awt.X11.XToolkit.<clinit>(XToolkit.java:126)	at java.lang.Class.forName0(Native Method)	at java.lang.Class.forName(Class.java:264)	at java.awt.Toolkit$2.run(Toolkit.java:860)	at java.awt.Toolkit$2.run(Toolkit.java:855)	at java.security.AccessController.doPrivileged(Native Method)	at java.awt.Toolkit.getDefaultToolkit(Toolkit.java:854)	at javax.swing.UIManager.getSystemLookAndFeelClassName(UIManager.java:611)	at kr.a(SourceFile:26)	at ko.aQ(SourceFile:385)	at net.minecraft.server.MinecraftServer.main(SourceFile:707)
    [Scales] [WARNING] This server has been detected as crashed by the management daemon. Restarting now...
    

    I've tried to find information on this error, but I feel like I'm missing some instruction somewhere. I don't know enough java to dig through the code either. If you need outputs of logfiles I'd be happy to send them to you. Otherwise it was pretty simple to install it on 16.04 when I fixed all the references to the older version of java.



  • This is actually due to using a desktop version of the distribution. Please add nogui to the end of your launch options for Minecraft and that should fix it.



  • Thank you, tested and worked.


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.