Questions



  • Hi! I found this software when searching for an alternative to multicraft, which is hard to use and expensive. I am also a developer, and I have a few questions.

    • do you support ubuntu?
    • what language is this written in? I'm assuming java.
    • what minecraft versions do you support?


  • I'm not sure what language it's written in, however I believe that it was written in more than one language.
    However, it does support ubuntu (https://pufferpanel.readme.io/docs/getting-started), an it supports all minecraft versions, as you can upload custom jar files, however by default MineCraft, BungeeCord, and PocketMine come installable with the panel and without having to upload your own jar file.



  • Thanks! I'm trying to install it & I already have Apache2 installed, but it's not recognizing that i have php installed! I KNOW I do, because I had multicraft & that "worked"...



  • Is there an installer argument to bypass errors?



  • Yes, we support Ubuntu and PufferPanel is tested with Ubuntu 14.04 LTS

    PufferPanel is written in PHP, and Scales (the daemon) is written in NodeJS.

    We support every version of Minecraft (PC) as far as we know. We also have some very basic support for Pocketmine.

    I recommend you follow the documentation and use nginx instead of apache if you are unsure about how to configure it, as we don't have documentation regarding apache. Make sure you have php5-cli installed otherwise the installer will not recognize PHP as being installed.



  • @puffrfish said:

    Yes, we support Ubuntu and PufferPanel is tested with Ubuntu 14.04 LTS

    PufferPanel is written in PHP, and Scales (the daemon) is written in NodeJS.

    We support every version of Minecraft (PC) as far as we know. We also have some very basic support for Pocketmine.

    I recommend you follow the documentation and use nginx instead of apache if you are unsure about how to configure it, as we don't have documentation regarding apache. Make sure you have php5-cli installed otherwise the installer will not recognize PHP as being installed.

    If you read my more recent posts, there is a more pressing issue.



  • @bobdabiulder Please make a thread in the Support section if you have further issues, but I did answer your question. Please make sure you have all of the dependencies listed on https://pufferpanel.readme.io/docs/getting-started including php5-cli otherwise the installer will not work.


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.