Trouble installing Pufferpanel



  • For some reason everytime I try to install pufferpanel, wherever the control panel should be is either the landing page for nginx, a 404 page, or just flat out refusing to connect based on my nginx config. I've followed the tutorial exactly and the system specs are:

    Centos 7
    nginx version 1.6.3

    My pufferpanel.conf file is http://pastebin.com/AsiXzH3W

    My nginx config is http://pastebin.com/m9W9L57a for the landing page.
    My nginx config is http://pastebin.com/NNYVHxj2 for the 404 page.
    my nginx config is http://pastebin.com/JSgXwa0M for the refusing to connect.



  • For some reason your nginx.conf has a server block in it which is conflicting with the pufferpanel.conf. I would recommend restoring your nginx.conf to its original state, you should not need to edit that.

    I am assuming your PufferPanel install is indeed located at the default location (/srv/pufferpanel), but if it is not then please move it there.

    Make sure the pufferpanel.conf is located in /etc/nginx/conf.d and that there are no other config files in there that could be interfering.

    You can grab the /var/log/nginx/error.log and /var/log/nginx/access.log and paste them to http://paste.ee and give us the URL it takes you to. That might be able to help us further.

    Please also run

    nginx -t
    

    and give us the output if there are any errors. Thanks.



  • Error.log http://paste.ee/p/Yuf9f
    Access.log http://paste.ee/p/9oR6Z
    No errors were shown from nginx -t
    pufferpanel.conf is located in conf.d and pufferpanel is located in /srv/pufferpanel

    all the files in /srv/pufferpanel have 755 permissions.



  • Changing permissions like that is quite unwise. I would recommend removing the /srv/pufferpanel directory and running through the installer steps again, starting with the "curl -L -o pufferpanel.tar.gz https://git.io/vaOuN" line.

    After the installer has been run, please try the following command:

    chown -R nginx:nginx /srv/pufferpanel
    

    For your reference, here is a default nginx.conf http://paste.ee/p/Rfeo9



  • I've done the steps again and I still get a connection refused. I'm using the nginx config file you gave me and ran the installer again. This time my error.log and access.log are empty and running nginx -t has no errors.



  • Can you please give the output of

    netstat -plunt
    

    Thank you





  • Looks like nginx isn't running. What happens when you this command?

    systemctl start nginx
    


  • It give no output and I still can't connect. running the nginx command does the same. netstat -plunt remains the same, no output to error.log or access.log.



  • What is the output of

    ps aux
    




  • Actually use this link, my terminal truncated some of the processes http://paste.ee/p/ww5sE



  • Let's just give everything a good restart to make sure

    systemctl restart nginx
    

    I really don't know why nginx is refusing to listen on port 80, this is rather strange. So long as you have your default nginx.conf or the one I posted, and the pufferpanel,conf in conf.d it should work. Let me know if it prints anything to the console when you try to restart nginx.



  • No output in console and it is still not working. I haven't had this much trouble with nginx ever, weird.



  • Try this just to make sure.

    Go ahead and copy the pufferpanel.conf somewhere safe.
    (as root for all of this)

    cp /etc/nginx/conf.d/pufferpanel.conf /srv/pufferpanel.conf
    

    Then remove nginx, install nginx, and copy back the config.

    systemctl stop nginx
    ps aux #check to make sure nginx is actually no longer running
    yum remove nginx
    rm -rf /etc/nginx
    
    yum install nginx
    systemctl start nginx
    systemctl enable nginx
    
    cp /srv/pufferpanel.conf /etc/nginx/conf.d/pufferpanel.conf
    systemctl restart nginx
    


  • Well, progress. I'm now getting a 404 page.
    Error.log http://paste.ee/p/cy95E
    Access.log http://paste.ee/p/3TUCl

    I also had to manually create the conf.d directory.



  • You ran

    chown -R nginx:nginx /srv/pufferpanel
    

    Correct?



  • I did. I ran it again to be sure and restarted nginx, still a 404 page.



  • So, I did some research and set me selinux into permissive mode, which is now giving me a 502 page.

    The error it is giving me is

    2016/05/07 22:29:06 [error] 15611#0: *4 connect() failed (111: Connection refused) while connecting to upstream, client: 99.98.172.255, server: 149.56.134.124, request: "GET / HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "149.56.134.124"
    


  • Can you paste the contents of /etc/php-fpm.d/www.conf ?


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.