How to access the panel after installation



  • I have installed nginx webserver (and completely removed apache2) on ubuntu machine then i successfully installed pufferpanel but i don't really know how to access it
    nginx and pufferpanel listens to port 81 (because i run a main webserver on the same ip, another machine) help me please

    pufferpanel.conf below
    http://pastebin.com/7LDWWJke

    im too noob because the instructions wasn't full-explanatory



  • type in the address thats in here

        server_name (i just hide it but i know how to fill this line);
    

    and with port 81

    so it should look somthing like this.
    yourdomain.com:81



  • @SirCoolness i typed the domain name and the port on the browser but i see the apache index page, its just left in /var/www while uninstalling nothing else



  • UPDATE i changed the root directory of nginx to /svr/pufferpanel/ and now for some reason the computer doesn't connect to "sub.domain.com":81



  • ohh your problem is that you cant have apache and nginx installed on the same server

    (how to remove apache2 ubuntu/debian)

    • backup your sites on apache2
    • run on your terminal sudo apt-get purge apache2*

    Im assuming you want phpmyadmin and/or you website powered by apache2 but keep pufferpanel on the same server. in short that wont work but you could setup virtual hosts.
    What a virtual host does is it allows you to use the same port for multiple website instances on one ip address and only have to type the domain. This is the best tutorial i found on how to setup virtual hosts.

    PS you could technically use apache2 for pufferpanel but you wont be supported.



  • Hmm no, i completely uninstalled apache as i said later (which no-phpmyadmin is a pain) and i connected to the panel but i have a problem with the scales now when running the auto-deploy script i get an error on curl, i will uninstall everything and reinstall again and comment what exactly is the current problem



  • Do you have curl installed
    If it is installed verify the installation script link is working. If you are still having issues please send a screenshot or text excerpt of the full error.

    Also you can keep phpmyadmin you just need to change the folder location.



  • This post is deleted!


  • sorry being blind for not enabling the pufferpanel site... anyway the main problem is that i can't run the auto-deploy script on the terminal because it needs https connection, i have self signed certificates but when i configure the pufferpanel.conf to use them the nginx service doesn't start (exit error code:1) wtf is going on anyway

    EDIT: Heres pufferpanel.conf on /etc/nginx/sites-enabled/ http://pastebin.com/7uje2nvt to check if i made something wrong



  • It seems you have a faulty config in nginx. Run nginx with this and tell me your error code.

    nginx -c /etc/nginx/nginx.conf -t
    


  • yeah as i said the faulty config is on the pufferpanel.conf which i pasted it in pastebin previously you may check it i think because i can't do anything else



  • @puffrfish you may help here please?



  • I'm not sure I really understand what is going on. You wish to run PufferPanel on the standard port 80, or port 81? In any case please paste the output of:

    sudo netstat -plunt
    

    to http://paste.ee and give us the URL it takes you to. I'd also like a copy of your current /etc/nginx/sites-available/pufferpanel.conf (not the one from before you made changes). Thanks.

    (also, hiding the URL of your panel does make it quite hard to diagnose issues. There is a limited amount we can troubleshoot without it or at the very least screenshots of your browser so we know what is going on.)



  • the port is 82 and the config is the same exactly the problem is that the nginx doesn't start because the config i provided before is broken it says code=exited, status=1/FAILURE when i try to start it... :(



  • Unfortunately if you don't provide the information asked it is incredibly hard to help you. Please provide the nginx configuration and the output of:

    nginx -t
    

    Thank you



  • This post is deleted!


  • @itzdriftyz Did you mean to delete your post?



  • @itzdriftyz said:

    i think i deleted something anyway

    url is play.ultroncade.net:82 but the service cannot start because the pufferpanel.conf i posted 2-3 comms before is broken (you may check it) also the output of nginx -t is :

    Job for nginx.service failed because the control process exited with error code. See "systemctl status nginx.service" and "journalctl -xe" for details..



  • Can you go ahead and grab that config file again and paste it to http://paste.ee? There seems to be some kind of issue with pastebin.

    You can also see if "journalctl -xe" like the error says gives you anything else. The more information the better.

    I notice you're using a home ISP. Make sure port 82 is forwarded on your router to the correct machine as well.



  • yes im using a home isp currently, i have ported the port 82 correctly and made some rules to iptables etc the problem is on the config pufferpanel.conf which is here http://paste.ee/p/DBkJI


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.