Black ESC in notepad++



  • Hi there,
    first of all I really wanted to say thank you to PufferPanel development teams having patience to help everyone of us out. Unfortunately , I jump into another problem this time at a whole different thing, it might not be a bug in puffer panel at all.

    So into the topic, I recently found out that the minecraft LOGs the NULL charact, /0 onto the server logs, and in notepad++ it displays like a black ESC thingy as shown in the photo attached, anybody facing the same problem as me or is there any solution to fix it?

    More info
    I have tried the --log-strip-color method but no luck ,

    alt text



  • Short answer:
    Maybe, but its not going to cause problems.

    Long answer:
    Those weird character [ESC] things is nodepad++'s nice way of saying that there are some unknown characters.
    they can occur if you open a non-text based file or unknown characters were typed.

    in your case it seems to be that when you typed the command into console and pufferpanel repeated the command.
    [ESC] probably represents the command and "[n" means next line.

    You could try updating notepad++ to the latest version and see if that fixes it but if it doesn't get fixed you don't need to worry because even it you delete them it wont destroy the server logs.



  • @SirCoolness Thank you for taking time to figure out this problem with me XD.
    I have found a permanent fix on this issue, with --nojline startup options.

    -Xms${memory}M -Xmx${memory}M -server -jar ${jar} --nojline

    This startup command will tell the java to not to care about those characters......sort of.... and it worked , everything turns out to be normal without house black ESC and "m"



  • ok well thats good to know
    thanks for sharing your solution.


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.