File permissions don't work anymore



  • Installed the latest pufferpanel and scales, using ubuntu server 15.10. Minecraft cannot create worlds, plugins cannot save to files. It was working in previous versions of pufferpanel/scales.

    Also, why does the website say beta 0.8.6 when it installs 0.8.5.3?



  • I have the same problem. Plugins giving errors like permission denied too.



  • @MFN
    You are uploading files by using ftp file manager or file upload by using pufferpanel?



  • @xion87 Using WinSCP, worked a while ago.



  • @MFN
    same thing, for me, time ago when you start the server it set all folder to correct owner, now they removed this feature, (dunno why) and everytime that i upload a file i have to set the correct owner/permission, i would like this thing come back again...



  • @MFN said:

    Also, why does the website say beta 0.8.6 when it installs 0.8.5.3?

    the version on the footer was not updated, but the software is.
    @MFN said:

    Installed the latest pufferpanel and scales, using ubuntu server 15.10. Minecraft cannot create worlds, plugins cannot save to files. It was working in previous versions of pufferpanel/scales.

    its possible that your installation script is broken. do you get any console output when your server starts asides for "your server has started"?

    PS
    for server installation plugins, it's possible some of the release installs are broken. scales will be replaced by pufferd and when that happens that kind of problem should not happen as much.

    you could modify the installation scripts if needed at (/srv/scales/lib/scipts/install).



  • @SirCoolness I doubt it's the installation script; I've reinstalled it many times. I get all the normal console output you'd expect of a minecraft server, world loading, plugins loading etc.



  • is only a visual bug, they forgot to change the numbers :)



  • Files need to be uploaded using the web interface or the SFTP user that the panel creates in order for permissions to be correct. How are the files being uploaded?



  • @MFN ah I misread it, I thought you were having issues during installation. I have to go with what @xion87 said, it sounds like something is screwed up with your file permissions.



  • @puffrfish Oh, that'll be where I'm going wrong. I'm using the root user to upload files to the server instead of the generated one.


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.