Welcome to the PufferPanel community forums! Please visit our discord for support: https://discord.gg/v8dz49e

Some strange issues with PufferPanel and Scales

  • Well, the router was rebooted, and there doesn't seem to be a difference.

  • I guess I'm going to have to reinstall again.

  • It doesn't sound like an issue that a reinstall will fix. Many home routers, especially those provided by ISPs do not handle connecting to "themselves" very well. You should look at the port forwarding settings on your router.

  • Well the thing is this has worked without issue for almost a year now. I first set it up last summer and it's worked fine until now.

  • I'd have to agree with puffrfish, It seems something in your environment is failing not scales or puffer itself. And even if it has been working does not mean it's scales or puffer that is failing. It could be an out of date repo or app, an update gone wrong. Check your firewall and check your routers firewall.

  • Nothing has changed any time recently though, except the database, even though that happened a day before.

    It's hard for me to believe that my router would just stop working suddenly. Reinstalling is the only option I see to try.

    Ubuntu is fully updated. That's the first thing I checked. Only Docker had an upgrade, and I don't even use that for this node.

  • Routers fail all the time and there's nothing that really tells you that they are failing or have failed. It could be even the router auto updated and change the configuration on you. If the router is ISP provided they tend to be pieces of shit ( excuse my language ).

    You can also try these to debug the connection too:
    From your PC try to ping the IP of the node to see if you are getting any kind of connection.
    When using curl make sure the url is https://localhost:port/ ( not http ) and use the -k option to ignore the ssl cert validation.
    If you've changed the FQDN of the scales install you might need to regenerate the https.key and https.pem. ( you can see how its done here form the auto install )

  • I've done all that. The router is an enterprise grade Cisco dual WAN router. I hope it hasn't failed.

  • So from what I understand is you have connection issues if your using scales via your public IP but not on local, if this is the case all I could recommend is to call your ISP and see if they are throttling your connection.

  • It seems to be only the server that can't connect to the public IP. I can get to Scales from outside the LAN (remotely). I scent l haven't tried another local computer, but I can do that a little later today.

Log in to reply