Some strange issues with PufferPanel and Scales



  • This happened very recently and very randomly. I don't believe I changed anything to cause this, so it might not even be an issue with PP or Scales.

    About an hour ago, I tried to start my Minecraft servers. I noticed PufferPanel was acting a little slowly, but it does that happens a lot, so I didn't think much of it. I started the server and it seemed to run well, but when I went back to the main page, it still showed the red icon with the X. I also noticed that the server status icons took a while to load in. When I went to start another server, I got An error was encountered with this AJAX request. (timeout). I have tried reinstalling Scales, and I've rebooted multiple times.

    I'm honestly not sure what to check or what more to provide, and I have no idea what could be wrong.



  • There are no recent logs in either /srv/scales/logs or /srv/pufferpanel/logs.

    I have also tried an in-place upgrade of PufferPanel, but it didn't work.

    One thing I forgot to mention: if I go into Settings>>List Nodes, the node is marked as offline, even though Scales is started and I believe is working.



  • Scales doesn't start itself when you restart your machine, so make sure it's started:

    cd /srv/scales
    ./scales start
    

    If it's started, make sure you can visit https://yourscalesipordomain:5656 (replacing yourscalesipordomain of course).



  • Oh, sorry. I forgot to include that part (derp). Scales is running, and I can connect to it perfectly fine. That's why this is so weird.

    I did do some database editing, but it worked after I did, so I don't think that's the problem (at least, I hope it isn't).



  • What did you edit in the database?

    Also, please grab the contents of any logs in /srv/logs/pufferpanel and paste them to http://paste.ee and give us the URL it takes you to. Is PufferPanel running on the same server as Scales? Make sure PufferPanel can connect by running this from wherever PufferPanel is installed.

    curl -k https://yourscalesipordomain:5656
    


  • I edited the FQDN, IP and port Scales was using. I also edited the URLs for PufferPanel, since for some reason I would get an invalid IP error if I tried graphically. But, like I said, everything worked fine. I have PufferPanel on port 80 because of ISP limitations and Scales on 8443 because of firewall and ISP limitations. I've let the curl command run for a bit from /srv/pufferpanel and so far it hasn't done anything.

    The auto-deploy script that the node creation gives also doesn't work if I use http://domain.com:8080/, but it does if I use the local IP.

    Scales and PufferPanel are on the same machine.

    The only log in the PufferPanel directory is a database connection exception from the 11th, but I'll post it. This is all there is:

    [2016-04-11 21-15-44] PDOException: SQLSTATE[HY000] [2002] Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) in /srv/pufferpanel/vendor/j4mie/idiorm/idiorm.php:255  @  http://domainname:8080/ajax/status  @@  exception--2016-04-11--21-15--26827981fc.html
    

    (I edited the domain name out, but it is the FQDN, not an IP.)



  • Seems like you're having communication issues between Scales and PufferPanel. It sounds like you're hosting this at home, which while possible is definitely something others have had issues with when it comes to being able to access a server from within the network using the public IP. Try that curl command but instead with a local IP. If that works, then it's probably due to your router.



  • Well, local works perfectly. I'll see if I can get the router rebooted.



  • Well, the router was rebooted, and there doesn't seem to be a difference.



  • I guess I'm going to have to reinstall again.



  • It doesn't sound like an issue that a reinstall will fix. Many home routers, especially those provided by ISPs do not handle connecting to "themselves" very well. You should look at the port forwarding settings on your router.



  • Well the thing is this has worked without issue for almost a year now. I first set it up last summer and it's worked fine until now.



  • I'd have to agree with puffrfish, It seems something in your environment is failing not scales or puffer itself. And even if it has been working does not mean it's scales or puffer that is failing. It could be an out of date repo or app, an update gone wrong. Check your firewall and check your routers firewall.



  • Nothing has changed any time recently though, except the database, even though that happened a day before.

    It's hard for me to believe that my router would just stop working suddenly. Reinstalling is the only option I see to try.

    Ubuntu is fully updated. That's the first thing I checked. Only Docker had an upgrade, and I don't even use that for this node.



  • Routers fail all the time and there's nothing that really tells you that they are failing or have failed. It could be even the router auto updated and change the configuration on you. If the router is ISP provided they tend to be pieces of shit ( excuse my language ).

    You can also try these to debug the connection too:
    From your PC try to ping the IP of the node to see if you are getting any kind of connection.
    When using curl make sure the url is https://localhost:port/ ( not http ) and use the -k option to ignore the ssl cert validation.
    If you've changed the FQDN of the scales install you might need to regenerate the https.key and https.pem. ( you can see how its done here form the auto install )



  • I've done all that. The router is an enterprise grade Cisco dual WAN router. I hope it hasn't failed.



  • So from what I understand is you have connection issues if your using scales via your public IP but not on local, if this is the case all I could recommend is to call your ISP and see if they are throttling your connection.



  • It seems to be only the server that can't connect to the public IP. I can get to Scales from outside the LAN (remotely). I scent l haven't tried another local computer, but I can do that a little later today.


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.