Welcome to the PufferPanel community forums! If you need help please register an account and post in the Support category.

socket.io + ssl problem



  • Hello. All steps of installation was fine but when i add server i can't see biuld progress. In browser network tab i see errors:

    Request URL:https://xxxxxxxxxxx:5656/socket.io/?token=5d2c90c3-768b-4ebc-a670-26554090a1f5&EIO=3&transport=polling&t=1460463970333-1
    
    net::ERR_CONNECTION_TIMED_OUT
    

    When i go to https://xxxxxxxxxx:5656/ i got the same error net::ERR_CONNECTION_TIMED_OUT.

    The scales is running:

    root@xxxxx:/srv/scales# ./scales start
    Starting Scales
    Process already running: 24246
    

    In proc.log is all fine:

    [2016-04-12 15:26:42] [VERBOSE]                                                                       Success! Everything compiled successfully. Copying final .jar files now. 
    [2016-04-12 15:26:42] [VERBOSE] Copying craftbukkit-1.9.2-R0.1-SNAPSHOT.jar to /home/pp-xmine-_wz3jk/public/. 
    [2016-04-12 15:26:42] [VERBOSE]   - Saved as craftbukkit-1.9.2.jar 
    [2016-04-12 15:26:42] [VERBOSE] Copying spigot-1.9.2-R0.1-SNAPSHOT.jar to /home/pp-xmine-_wz3jk/public/.
    [2016-04-12 15:26:42] [VERBOSE]  
    [2016-04-12 15:26:42] [VERBOSE]   - Saved as spigot-1.9.2.jar 
    [2016-04-12 15:26:42] [VERBOSE] installer:~$ mv spigot*.jar ../server.jar 
    [2016-04-12 15:26:42] [VERBOSE] installer:~$ rm -rf * 
    [2016-04-12 15:26:43] [VERBOSE] installer:~$ mv ../server.jar server.jar 
    [2016-04-12 15:26:43] [VERBOSE] installer:~$ chown -R pp-xmine-_wz3jk:scalesuser * 
    [2016-04-12 15:26:43] [VERBOSE] installer:~$ exit 0 
    [2016-04-12 15:26:43] [VERBOSE] Updating root folder perms
    [2016-04-12 15:26:43] [VERBOSE] <Buffer >
    [2016-04-12 15:26:43] [VERBOSE] <Buffer >
    [2016-04-12 15:26:43] [VERBOSE] Installer process has completed for for 9ae2af84-b90f-424c-97b1-0420ca38161d
    [2016-04-12 15:26:43] [VERBOSE] Major install process completed and PufferPanel notified.
    

    When i go to the server control page i see:

    We were unable to connect to the main Socket.IO server, there may be network issues currently. 
    

    What is wrong?



  • I would make sure there isn't another instance of Scales running. Occasionally this happens as the ./scales script is not perfect.

    ps aux
    

    You should be able to use "kill" to kill any copies of Scales (might say nodejs).

    kill -9 20045
    

    Then start up Scales again and see if you can navigate to https://yourscales:5656. If that works then the issue should be resolved, if not let me know.

    cd /srv/scales
    ./scales start
    


  • Unfortunately it is 1 instance of scales:

    root@xxxxx:/srv/scales# ps aux | grep scales
    root     12727  7.4  0.6 966516 55272 ?        Ssl  18:48   0:02 /srv/scales/node/bin/node /srv/scales
    root     12747  0.0  0.0  12728  2036 pts/0    S+   18:49   0:00 grep scales
    

    i am restart scales, but page https://yourscales:5656 is still show net::ERR_CONNECTION_TIMED_OUT.



  • Is there something like CloudFlare on the domain you are using or some other kind of firewall? What happens if you do:

    curl -k https://127.0.0.1:5656
    


  • Result:

    root@xxxxx:/srv/scales# curl -k https://127.0.0.1:5656
    "Scales Management Daemon"root@xxxxx:/srv/scales#
    
    
    root@xxxx:/srv/scales# curl -k https://scales_domain:5656
    "Scales Management Daemon"root@xxxxx:/srv/scales#
    

    System is a fresh install of Debian 8, i am not make any settings in firewall.
    As NS servers i use cloudns.net it is only gives NS servers. Nothing else.



  • It appears as though it is a networking issue though if you are able to get that response from within the server. Is this server hosted at home or is it a VPS or dedicated sever from a hosting company? If it's hosted at home you probably need to forward port 5656 on your router.



  • Oh, you are been right! My iptables was configured by vesta control panel, i just add rule to accept 5656 port and all is going to be working! Thank you!

    root@xxxx:/srv/scales# iptables -A INPUT -p tcp --dport 5656 -j ACCEPT
    


  • Glad you got it working.


Log in to reply
 

1
Online

666
Users

708
Topics

3.2k
Posts

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.