SSL problem



  • Hey,

    so i just started using pufferpanel and i love it. But im having a problem with both socket.io and can't connect to the main server some times (already tried reinstall once and 2nd time putting everything on domain).

    So im not hightech when it comes to SSL, and im having untrusted SSL to my daemon and i guess after all my searches this is the problem. The thing is after all my googling and searching i still have no clue how to fix this.

    Any solutions how to fix the untrusted SSL ?



  • The message about SSL shows because you are using a self-signed certificate, so your browser needs to accept that certificate. If you click the message that pops up it should redirect you to https://yourscalesIPorDomain:5656 where you can accept the certificate in your browser.

    In order to get a signed certificate, you will either need to pay for one or use something like LetsEncrypt.

    That being said, it sounds like you may be having some issues with Scales outside of that. Please check /srv/scales/logs/proc.log and any logs in /srv/pufferpanel/logs and paste the contents of them to http://paste.ee and post the URL it takes you to if you are still experiencing issues.





  • How about that proc.log from /srv/scales/logs?



  • No prog.log in the folder, i got error.log/exception 2x html files / exception.og and info.log



  • Those are the logs from /srv/pufferpanel. Please go to /srv/scales/logs instead.



  • Just tried starting up the server again (minecraft), worked. But this is after reinstall, had the problem in the beginning. But im gonna give it an hour or so, because first installation i had no problem until a few hours later.



  • Has this been resolved?


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.