"Unable to connect to daemon to process this request." - File Manager



  • Hello,

    Since updating to 0.8.6 I have been getting this error , I have also updated scales and restarted it a few times since to see if that was the issue but it it doesn't appear to be.
    Does anyone have any ideas on how to resolve this?

    Thanks.



  • Could you please provide the Scales log located at /srv/scales/logs/proc.log? You can paste the contents to http://paste.ee and give us the URL it takes you to.





  • Sorry about the delay, were you able to resolve your issues? Your paste has expired unfortunately.



  • Hi,
    I was unable to resolve and ended up uninstalling Puffer.
    I tried reinstalling today and I've been getting a Java install error (not Puffer), is there a way to ignore the Java install as I am just going to reinstall it as Java 8.
    Thanks.



  • Could you post the error you are receiving? Thanks





  • The issue appears to be that you have held packages relating to openjdk-7-jre for some reason, but you can edit this line in the script the panel generates to tell it not to try to install openjdk-7-jdk.

    You'll have to grab the install script from the install command (don't just copy and paste the command it generates into the terminal).

    Find the deploy script's URL from the install command, it should look something like http://panel.yourdomain.com/auth/remote/deploy/dc05fbb7-fef2-4497-8044-03ee4aa8d70f.

    Now run the following commands, replacing the url of the script with the one found in the install command.

    cd /srv
    curl -k -o install.sh http://panel.yourdomain.com/auth/remote/deploy/dc05fbb7-fef2-4497-8044-03ee4aa8d70f
    

    Now find the line that looks like

    apt-get install -y openssl curl git make gcc g++ nodejs openjdk-7-jdk tar python lib32gcc1 lib32tinfo5 lib32z1 lib32stdc++6
    

    and remove openjdk-7-jdk from that list. Save the file and run it.

    sudo ./install.sh
    

    That should work. Let me know how it goes.



  • Hello,

    Thanks that solved that.
    As for the original issue its not currently reproducing the error but last time it took a few days, if anything happens i'll reply to this thread.

    Thanks.


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.