Port mapping not working.



  • So I've got the following in my /srv/scales/data/uuid-here.json file: http://hastebin.com/yatigadiwu.
    But I'm getting "self.emit is not a function" when trying to rebuild the docker container.

    Am I doing something stupidly wrong?

    Regards, Incrementing.



  • We've just released a new version of Scales that should fix this issue. Please follow the directions located here in order to update your Scales installation.



  • Still doesn't seem to be working...
    Can you please double check im getting this .json file correct.

    .json: http://hastebin.com/verodoyube.pl
    'netstat -tulpn' output: http://hastebin.com/dimahodavi.hs

    As you can see in the netstat output the port '8192' still isn't showing.

    Regards, Incrementing.



  • Your file from before looked fine, but the one you just posted does not.
    Something like this should work. Make sure to rebuild and restart the container afterwards.

    {
    	"name": "247ef962-8ff1-4ad9-ac7e-dbfcf3e934bc",
    	"user": "pp-factio_zy6pd",
    	"build": {
    		"mapping": {
    			"198.XXX.XXX.145": {
    				"25565": "25565",
    				"8192": "8192"
    			}
    		},
    		"disk": {
    			"hard": 32,
    			"soft": 32
    		},
    		"cpu": 0,
    		"memory": 4096,
    		"io": 500
    	},
    	"startup": {
    		"command": "-Xms${memory}M -Xmx${memory}M -server -jar ${jar}",
    		"variables": {
    			"jar": "spigot.jar"
    		}
    	},
    	"keys": {
    		"091b867c-fb03-4783-85ba-ef5f3211528f": [
    			"s:ftp",
    			"s:get",
    			"s:power",
    			"s:files",
    			"s:files:get",
    			"s:files:delete",
    			"s:files:put",
    			"s:files:zip",
    			"s:query",
    			"s:console",
    			"s:console:send"
    		]
    	},
    	"gameport": 25565,
    	"gamehost": "198.XXX.XXX.145",
    	"plugin": "minecraft"
    }
    


  • Okay, It still doesn't seem to be working.
    I'm pretty sure i'm doing something very stupidly wrong... By "rebuild and restart the container afterwards." you mean

    1. Power off (mc) server.
    2. AdminCP->Server->Rebuild Container.
    3. Power on (mc) server.

    correct?
    (also the 198.XXX.XXX.145 is the public IP not an external ip).



  • Looks like there might still be a bug. Still trying to figure out the cause.



  • Okay, Let me know when there is a fix.

    Regards, Increm.



  • To help, could you please provide the contents of /srv/scales/logs/proc.log? You can paste it to http://paste.ee and give us the URL it takes you to if it is quite long.



  • Done, It's right here.



  • @puffrfish Any updates? Kinda need the port open asap.
    Sorry to be a pain.



  • @Incrementing If you do not need docker (probably only necessary if you are running a GSP) you can disable docker by setting docker: false in the config.json located in /srv/scales


Log in to reply
 

Looks like your connection to PufferPanel Community was lost, please wait while we try to reconnect.